This object is in archive! 

Can't direct connect to server

David McDonough shared this bug 19 months ago
Won't Fix

When trying to direct connect to an IP, I get this screen for a few moments and then it drops back to the main menu.

ce53e705d47976c18460404440ad2cc9

There is a dialog that appears behind the other dialog, I don't know if it is an error or asking for the server's password, either way it was not helpful and I had to join via steam. Also why is it kicking me all the way back to the main menu? This UI needs some love, and it also needs to work properly.

Replies (2)

photo
1

Hello, David,

So I tried it in similar way as you did and it was working for me every time. From what I know, the window behind the "Joining" is just the "Direct connect" window, as you saw it before, when entering the address. The password window would appear in lower part of the screen. So there is no issue in this.

Is it vanilla server or with some mods? Are you sure you´re running the game in appropriate mode (safe/experimental), that matches the server settings? Is the server and your game on the same game version? Does this still happen to you, or was it just once/one day issue?

Did you try to connect to DS? Was it your DS, your friends´ or some random server? Is there a password or not? Can you send us the save of that server, please?

Also if there is any message about why you didn´t get connected to server in logs, that would help as well.

You can access your save files by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineersDedicated\Saves.

Please zip the file and attach it here. If you are having difficulty attaching files you can optionally use Google Drive. When sharing a google drive link please make sure it is set to be downloadable by anyone with the link.

Kind Regards

Keen Software House: QA Department

photo
1

Hello Engineer,

Since there are no new comments in this topic and we are still not able to reproduce it, we are closing this thread as outdated.

In case anyone is encountering the same or similar bug, which is not already posted in a different thread, please feel free to create a new thread with all relevant information.

Thank you.

Kind Regards

Keen Software House: QA Department

Replies have been locked on this page!