"Graphics driver crashed" - KB5013887 Windows Update

Marco Leise shared this bug 2 months ago
Solved

Heads up that after installing KB5013887, I cannot load into the game. It either crashes with the well known graphics driver message or locks up. The log files show an "out of memory" situation. This has happened before with a too small page file. But after the update it became excessive to the point where 32 GB of combined memory is often not enough to load into the main menu.


System:

Win 10 Pro 21H2, i5-9400F, RX Vega56 8 GB, 16 GB RAM + 16 GB page file

I uninstalled KB5013887 for now as a workaround. The description of the update lists among other things:



  • Addresses several issues that would cause too many garbage collections under high memory load. The part of the change that reduces the number of blocking generation 2 collections under high memory load is considered a tuning change and is only active if the GCConserveMemory setting is set to a non-zero value. The part of the change that reduces needless generation 0 collections is considered an improvement and is always active.
  • Adjusted GC Heap Hard Limit configuration, as well as processor interpretation for .NET Framework container scenarios.


Replies (1)

photo
2

Hello, Marco,

sorry to hear that you are suffering with this issue and thank you for letting us know.

However, I do not see much in the logs your provided, that could point towards some easy fix.

Can you please try to delete your Launch options that you are using? Namely I mean these: "-nosplash", "-skipintro" and "-plugin "..\..\..\workshop\content\244850\2407984968\RunPluginLoader"".

If this won't help you in order to run and play the game normally, can you also please try these steps:

  • Verify your game files in Steam -right click on Space Engineers in Steam Library → Properties → Local Files → Verify Integrity of Game Files
  • Delete SpaceEngineers.cfg file (it means your game configuration will be deleted) – you can access your SpaceEngineers.cfg by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers.
  • Delete ShaderCache folder – same access as above
  • Back up your whole Space Engineers Roaming folder and delete it
  • Restart Steam
  • Reinstall VC Redist 2017
  • Update graphic drivers
  • Reinstall the game
  • Make sure your operating system is fully updated

Hope something from this would help you. Please let me know.

Kind Regards

Keen Software House: QA Department

photo
1

Thank you for the help, Ondrej! After trying all your suggestions and seeing how no one else got affected it became obvious that this must be a system config issue, and sure enough I had the COMPlus_GCHeapHardLimit environment variable set which only started affecting SE since KB5013887. The ticket can 100% be closed.

Best regards,

Marco

photo
1

Hello, Marco,

thank your for comming back to this thread with an update.

I'm happy to see that you manage to fix this issue and you are able to play again.

As there is no further assistance needed from our side, I will close this thread.

Kind Regards

Keen Software House: QA Department

photo
Leave a Comment
 
Attach a file