Japanese IME Bug?

ponzu 0124 shared this bug 6 months ago
Reported – Awaiting fix

I can't press OK or Check Code in the Programmable Block code editor when switching to Japanese input during the game. Cannot be fixed by restarting the game It will be fixed by shutting down the PC.

Replies (1)

photo
1

Hello, ponzu 0124!

Sorry to hear you're experiencing this issue. I am not familiar with changing the IME to a different language but have installed the Japanese language pack and changed it but I have had no change in anything relating to Space Engineers. I have tried this multiple times with the same result. Could you please supply reliable steps on how you have come to the issue? I can then test this in the exact same way you have done it :)

Kind Regards

Laura, QA Department

photo
1

It seems that it is necessary to change the hardware keyboard layout to 106/109 for Japanese to reproduce it. Then you need to click IME in the taskbar to change A to あ while the game is running.

photo
1

Hello, ponzu 0124!

Thank you for the further information. I have done as you say, changed the hardware keyboard layout to 106/109 for Japanese, then clicked IME in the taskbar and changed this. I have been unable to see any changes and I am able to check code or click OK without any issues. Do you get any issues if you change this and you are not in the programable block? Or, in any other games? Also, are you running any mods at all?

We do have some general steps which cover a wide array of issues that may be worth trying to see if this helps at all. I would try these and see if this helps at all with the issue.

  • Verify your game files in Steam

  • Right click on Space Engineers in Steam Library → Properties → Local Files → Verify Integrity of Game Files

/N3EfoyXb7I11OqPD41YrEEkpLvMEOet0DklVIYjse2HivN8HcQfUj3yaKe3lSLX_QBV8PbU5pahR4nDUvDaTFtFvA_EdYa8y513rK9XvMbQSeiyoOGn6-ga2Hj-VSQ9KuuPp_xaM8yPTVpOdDA

  • Delete SpaceEngineers.cfg file

  • It means your game configuration will be deleted
  • You can access your SpaceEngineers.cfg by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers
  • Back up your whole Space Engineers Roaming folder and delete it
  • Restart Steam
  • Reinstall the game
  • Make sure your operating system is fully updated

Kind Regards

Laura, QA Department

photo
1

It seems that a bug occurs when switching to Japanese IME and pressing the tilda key to change to Japanese input.

photo
1

Hello, ponzu 0124!

Thank you so much, it was the extra key that did it. I have reproduced the issue and reported this internally :)

Thank you for all the information.

Kind Regards

Laura, QA Department

photo
Leave a Comment
 
Attach a file