EOSOverlayRenderer-Win64-Shipping remains running

Jon Atkins shared this bug 6 months ago
Won't Fix

Space Engineers launches multiple "EOSOverlayRenderer-Win64-Shipping.exe" processes when launching. Often (>50%) one of these processes remains running on exit. This running process means Steam thinks the game is still running and refused to launch it again until I kill the process.

As far as I can tell, Space Engineers uses Epic Online Services (EOS) for it's cross-platform PC/Xbox multiplayer support.

This has been happening for a while now. Not sure when it started, but probably every since cross-play support was added?

Is it possible to just disable the use of EOS? I don't play online so that would be a simple fix.


Attached is a log file from just launching the game and exiting from the main menu. Nothing stands out to me in here.

Replies (5)

photo
1
photo
1

Hello, Jon!

Sorry to hear you're expereincing issues. I have been trying to reproduce the issue with repeadidly starting Space Enigneers but I don't appear to be expereincing anything like you're mentioning. You say it's been happening a while but is this happening every single time you launch the game? Do you have to force quit the game each time? Do you have to force quit the game if you don't enter into a world at all and just exit the main menu without starting a game or, is this after an extended period of playing the game? Any further infomration would be a great help.

I would suggest the following as these are usual steps which can fix a wide array of issues incase this helps your current issue.


  • Verify your game files in Steam

  • Right click on Space Engineers in Steam Library → Properties → Local Files → Verify Integrity of Game Files

/U5bOgrsG50XKgFEj2KrehIbyXCU--NoWAD8GTUlojkd2ZFraBt3jLXspXEifvTQIMReWRRAZbQffkh4l9Z31KweRyfMEucd07NEP7103aiFg8-VUzM94s_8R0Kk8AFY072iIbh7E6shs7bC3-g

  • Delete SpaceEngineers.cfg file

  • It means your game configuration will be deleted
  • You can access your SpaceEngineers.cfg by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers.

  • Delete ShaderCache folder

  • Back up your whole Space Engineers Roaming folder and delete it
  • Restart Steam
  • Reinstall VC Redist 2017
  • Update graphic drivers
  • Reinstall the game
  • Make sure your operating system is fully updated

Kind Regards

Laura, QA Department

photo
1

Yes, it happens when launching and immediately exiting the game - the attached log file above is an instance of that.

It happens more often that not, but occasionally it hasn't been an issue. As the game itself exits cleanly I don't notice the problem until I try to launch it again, possibly a day or two later (without a PC restart). Restarting steam hides the problem - the EOS-Overlay process remains running, but steam no longer realises it's related to Space Engineers.


There's no useful EOS related log entries in that file. Would there be useful logging elsewhere for this?

Is there anywhere I can go to get support directly from Epic Games for their Epic Online Services and related overlay? I've not managed to find anything myself. Or can you send Epic feedback for this?


Is there a settings in SE to disable EOS, or online access in general? I've not found anything obvious in the game settings or the config file,

photo
1

Hello, Jon!


We have tried replicating the issue on our end, but unfortunately, we haven't encountered it.


Can we ask if you have tried the steps we mentioned in our previous response? In case you haven't tried them yet, we recommend trying them and seeing if the issue persists.

If you have already tried those steps and are still experiencing the issue, could you send us the new log file where you're experiencing the issue and a log from the Windows Event Viewer as well?


Kind Regards,

Keen Software House: QA Department

photo
1

Hello, Engineer!

Because there is no new comment from you, and we are unable to reproduce the issue on our own, I will close this thread now as outdated.

If you or any other player will experience this issue again, please make a new thread and provide all needed info there.

Thank you for understanding.

Kind Regards

Keen Software House: QA Department

Leave a Comment
 
Attach a file