Me and my friend cannot connect to each others world

DrunkBirch shared this bug 6 months ago
Solved

Me and 2 of my friends started a multiplayer solar system world about 2 weeks ago and at some point decided to add mods into it. It was all good at first but then one of my friends just couldn't connect anymore, while the other friend is completely fine. We tried pretty much everything (updated drivers, changed server settings, he tried fixing his firewall, router) but the issue still persists. Moreover, when I put up the world on Steam workshop and he downloaded it and hosted it, the issue started occuring to me. I couldn't find any helpful info on this so I'd be grateful if you could help me out.

Additionally, I provide logs for the last 2 days of us playing.

Replies (3)

photo
2

Hello, DrunkBirch!

Thanks for letting us know about the issue that you are experiencing.

However, as you are writing, and it's also clearly visible in the logs, the issue would most likely be because of the mods.

If I get it right, the game was working just fine when you played in vanilla (without mods) and the problems started to appear as soon as you tried to put the mods in, right?

There are re-appearing errors in all these logs:

Reference issue detected (circular reference or wrong order) for mod Steam:806331071

Reference issue detected (circular reference or wrong order) for mod Steam:1918681825

MOD_ERROR: Aryx Weapon Enterprises [WeaponCore]

I believe this is the origin of the problems you are writing about.

Is the game running fine when you delete the mods from this world or start new game without any mods?

If yes, I believe there is unfortunately nothing we can do for you at the moment. Please keep in mind that we do not and can not provide support for mods, as there are hundreds and probably thousands out there. It's the mod creator/owner responsibility to make sure there are no issues with his mods and they are working properly with current version of the game.

Please try to delete mods from the game and run it or start a new game without mods. If the problem would still occur, can you send me the new log without mods loaded in and share me the save file as well (here or through Steam workshop) so I can take a look myself?

You can access your save files by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers\Saves. There should be a folder with your SteamID and your saves.

Please zip the file and attach it here. If you are having difficulty attaching files you can optionally use Google Drive. When sharing a google drive link please make sure it is set to be downloadable by anyone with the link.

If the problem won't happen without mods, please contact the mod creator and let them know about your situation.

Kind Regards

Keen Software House: QA Department

photo
1

Thank you for your advice. You were right, it was a certain encounter mod that was causing it. I appreciate your help with this!

photo
1

Hello, DrunkBirch,

thanks for comming back and letting me know.

Happy you are not longer experiencing this issue.

As there is no more action wanted on our side, I will close this thread.

Kind Regards

Keen Software House: QA Department

Leave a Comment
 
Attach a file