[187.209] Static grids don't merge

Digi shared this bug 23 months ago
Considered

A player sent me a world that had issues with airtightness. The issue turned out to be that a portion of the ceiling of the station was a separate grid (see attached thumb.jpg).


I cleaned up the world leaving only the station, the ceiling part and its attaching asteroid.

I recolored the separate grid pink so it can be obvious, see attached zip file.


Once you load the attached world try to merge those grids together. I've tried simply placing more blocks to unite them and even merge blocks, neither worked.

You can look at the entity list to see if they're still 2 grids.

Comments (2)

photo
1

It seems the cause is the turret on the outside of the asteroid, they placed that first and its bounding box intersects with an armor block there so they can't merge.


The issue here is the lack of player information, it needs to inform the player that it didn't merge and why.

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.


We will address all reported issues during future development and we will attempt to fix your issue as soon as possible. We are currently close to a Major release, which is under heavy development and this takes up a lot of our time.


Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards


Keen Software House: QA Department