[1.191.108] Memory leak

Marco Leise shared this bug 13 months ago
Considered

I's seeing increasing memory use after a few laps on the race track linked below. Every time I reached the finish line and reloaded a save game with me at the start. After about 6 laps (which takes about 1h 30m) the memory use looks like this:

91441eb3d694eb0d32b265f9f6d41f6b

System:

Windows 10 1903, 16 GB RAM, AMD Vega 56, Intel Chipset, pagefile on a HDD

When I originally had crashes due to memory leaks and created the save game, it was 06/26/2019. I think since then it got better, as back then I would notice the swapping on the first lap already (stuttering) and now it seems more concealed.

EDIT: The difference may come from a change I made to the pagefile: fixed size of 62.5 GB now instead of system managed, which would be the default.

Reproduction steps

Drive several laps on this map and the memory use should start to increase:https://steamcommunity.com/sharedfiles/filedetails/?id=1772272553

After each lap reload with F5 to start the next one. After lap 1 or 2 memory use may drop slightly, but in later laps it wont come down again.

A faster way

Disable the swap file and drive for 4min 30sec on a 16 GB system. (Quick access: Win+R: SystemPropertiesPerformance /pagefile) The game should crash (or at least it did that back in June ;-) ).

Comments (3)

photo
1

Hello, Engineer!


Thank you for your feedback! Yourtopic has been added between considered issues.

Please keep voting for the issue asit will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

I have this PC:

Motherbord: Asus TUF Z270 Mark2 LGA1151

Processador: Intel core I7 7700K CPU 4.2Ghz

Placa de Video: Asus Geforce GTX 1080 TI 11GB

RAM: Corsair Vengeange LPX 2x16GB 32Gb DDR4

Fonte: Nox URANO VX 750W

And after i play like 5m : http://prntscr.com/oxbwsh" rel="nofollow" target="_blank">http://prntscr.com/oxbwsh">http://prntscr.com/oxbwsh

photo
1

Geforce Experience was known to set the voxel detail in SE to "Extreme". Can you check your game options to verify that this is not the cause? If the voxel details are "High" or less, you should upload the contents of a save game folder (don't need the backups) so it can be reproduced.

photo
photo
1

Hello, the voxel is set to extreme

http://prntscr.com/p3e8zp

CZca3nicQaWZHKncT9HorQ

Screenshot

Captured with Lightshot

prntscr.com