[1.188.024] Custom Ores Not Being Detected

DranKof shared this bug 2 years ago
Solved

Since this last major update, any custom ores added by mods are not being registered with the ore detectors or hand drill.

The fastest way I know to replicate this bug is using the mod:

https://steamcommunity.com/sharedfiles/filedetails/?id=406244471

When you load the Easy Earth Start, there should already be custom ores within range of the detector just outside the main central door. You can also use the voxel hand to add any of the custom ores right next to you, and even when you use the hand drill they won't be detected.

They are marked in the game data exactly as all the vanilla ores with "<IsRare>true</IsRare>" and they worked in 1.187 (the mod was just updated) and the mod author has done his best to confirm that nothing else about the API has changed that it should exclude custom ores from being detected.

The mod has comments from about 4 other people that can concur this issue.

Though it seems similar to other peoples' bugs stating that ores weren't appearing, this affects new games and frankly no one reports any problems seeing the vanilla ores from new or old games on the mod thread.

Comments (2)

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.


Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards


Keen Software House: QA Department

photo
1

Update: This bug seems to have been solved in update 1.188.1. It may have been related to:

  • Fixed multiple types of ice not being detected by ore detector
  • Fixed ore detector not detecting ores in specific ranges
  • I asked Nov 23rd if anyone else still had any problems and no one seemed to have any. Thank you very much.