[1.187.209] Autojoin SPID on Serverjoin

Abisius shared this bug 3 years ago
Outdated

i have found a rather devious bug that causes everyone that first joins the dedicated server that i have setup after some time to be automatically assigned as a member of the SPID without beeing listet on the factionpage of the SPID and also without the option to leave the faction or joun another, the butons seams to be missing outgoing from the reports i have become from the users for they it happened.


after resetting the world and deactivating wolves and spiders it dont seams to have happened again until now.

i would like to attach the worlfiles but a 2gb zipfile seams to be too much for the site and even after over a hour of waiting the upload got stuck at around a mousewide piece of the upload.


also i have noticed that both the SPID and the SPRT are reset to accept everyone after every serverrestart, this happens even with wolves and spiders deactivated.

Comments (6)

photo
1

I find this Bug happens when you make a world in SP then move over to a dedicated Server.

And are you using any NPC based mods.

photo
1

no npc based mod and generated and manage the world from the dedicated server tool that comes with the steam cmd install of the game.


testing shows that it even happens without any mod in the server as long as wolves and spiders are active

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

We will address all reported issues during future development and we will attempt to fix your issue as soon as possible. We are currently close to a Major release, which is under heavy development and this takes up a lot of our time.


Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

I am playing single with wolves on and after killing a couple I have a reputation decrease with the SPID faction.

Oi those sneaky bastards! While pretending to be neutral they send bloody wolves to me base! I will send them back some power cells as an aknowlegment note, in a self-driving turret as a casing!

photo
1

Oh, that actually not a bug. Sorry, I am new, still learning the basics! Wish I could remove misguiding comment.

Found the factions window where it says that SPID means "Spiders" and they are hostile -- that makes sense! I thought that all factions are human. Like, how exactly wolves will form a faction, right? That woulld be some Rudyard Kipling stuff.

photo
1

This bug has been present for years, there were multiple threads about it on the forums from before this site was created.

photo
1

Happened to me as well on a server, unable to leave the space spider faction. It says 'are you sure you want to leave' and then nothing happens. Since its another's server, unable to do anything about it myself.

photo
photo
1

since players and servers can no longer use Midspace Admin helper commands mod that was keeping this bug under some level of control, due to code changes, this problem has 'blown up'...