World won't save

Arca shared this bug 6 months ago
Submitted

Hi,I couldn't save my world anymore for no reason. the notification after saving a world do not appear, i tried to activate auto-save, and save the world with another name, with no succes.

Here is my world : https://steamcommunity.com/sharedfiles/filedetails/?id=1834579790(it happened to me once, it was because of lack of storage, but now there is no special reason)

I don't want to rebuild all my city so please debug this :(

Thanks.

Comments (3)

photo
1

this is a very bad and annoying problem i love the game but that drives me crazy


i am in a solo offline world, and the game seemingly does just not safe at all

not anymore i got a lot of nice worls and a few nice survival castles.

and i want to start a new, game but i can't save so i spawn everytime at the same spot, all my progress gone.

when i press "save game" it does aks if i want to save, i press yes, and then i go back into game and i noticed ther eis no information like usual like "Game saved"


what shall i do?


sounds exactly like your bug and i tried the same in another offline solo world, and it also won't save, there is no game saved or such not game already saving jsut nothing, and i worked until 2-3 days ago.

till then i play the samee fricking save again and again and it just won't save

photo
1

I am having the identical problem. I thought I might have run out of save space or something, so I deleted a bunch of old save files, but that didn't help. The game will not autosave, save, or save as. Nothing happens. I cannot make any progress whatsoever until and unless this problem is resolved. This is a game-breaker.

photo
1

I discovered what the problem was in my case: the save was corrupt. This was not apparent until I closed out the game and tried again the next day. Before I had exited the game, it could still load the corrupt file and reacted exactly as you describe - not saving anything that I had done, respawing in the same place no matter where I was, unable to save or save as. I suspect what happened to me is that my game was attempting to autosave and appeared frozen and when I killed the program - it corrupted the file. I went back to the previous file I had saved right before and it opened up and seems to be working normally.

I keep incremental backups, fortunately. Every 10-20 minutes I will "save as" under a new name. I keep milestone saves forever - labelling them before I make some kind of major change, and then all the rest of the old saves get cleaned up periodically.

I can't say if this might help either of you - but it might. Good luck!