"World corrupted" when trying to load anything

Xaerthus shared this bug 2 years ago
Submitted

Hello!

Me and my friend are playing ME together (I'm being the host) in a world maybe a week old. Since yesterday (2019-02-22) my friend cannot join my world: when he tries he get to 18% loading and then gets a message that the world is corrupted and cannot be loaded. We tried older backups thinking the world got corrupted but same issue occured. After that trying to load any world on his side (even any of the default new worlds without any mods) resulted in said message. On my side everything seems to work fine.

He has tried to check his files with steam, even a full reinstall of ME. Nothing seems to help.

I'm attaching our save, logs of both of us and printscreen of that error message.

Comments (1)

photo
1

Looks like i've possibly found the culprit: the metadata.mod files in his local blueprints were throwing an exception on any worldload he tried. After deleting those it seems to work.