[ME 0.7.x MP] Plow errors, Seeder doesn't work, Crops disappearing and endless animation loops

Todd (shortybsd) shared this bug 6 months ago
Solved

Made a little pull type of plow and seeder. When plowing fields it leaves repeated exploding dirt all over the place. Reboot server and client, looping particle effect is gone until you plow again. Manually planted a ton of flax like 8 - 10 bags (80-100 crops) they were almost grown. Logged out last night, logged in today poof they were gone. I am done reporting bugs for a while until they patch all the major ones. Might have to consider rolling back to 0.6 and leaving this one alone. It is pretty much not playable at the state it is in. Again, Keen is a great company and do fantastic work. I am just shocked they released it in the current condition.

Seeder doesn't even work. You can pull forwards, backwards dismount, remount it. Doesn't work on multiplayer at all.

Plow errors after hitting "F" to activate it.

2019-02-16 09:26:21.138|Main Thread> Error: Dictionary mapping controlled entity to identity is inconsistent between server and client.
2019-02-16 09:26:36.804|Main Thread> Error: Dictionary mapping controlled entity to identity is inconsistent between server and client.
2019-02-16 09:26:37.608|Main Thread> Error: Dictionary mapping controlled entity to identity is inconsistent between server and client.
2019-02-16 09:26:38.411|Main Thread> Error: Dictionary mapping controlled entity to identity is inconsistent between server and client.
2019-02-16 09:26:55.281|Main Thread> Error: Dictionary mapping controlled entity to identity is inconsistent between server and client.
2019-02-16 09:27:08.336|Main Thread> Error: Dictionary mapping controlled entity to identity is inconsistent between server and client.
2019-02-16 09:27:10.143|Main Thread> Error: Dictionary mapping controlled entity to identity is inconsistent between server and client.
2019-02-16 09:27:14.029|Main Thread> Process information Periodic 
2019-02-16 09:28:11.248|Main Thread> Error: No valid state change for dummy on MyStateUseObjectComponent! StateUseObjectComponent:PlowBlock, dummy: detector_plow
Note this is a non-modded vanilla server. Restart both client and server same error.

Comments (2)

photo
2

Update: Server was updated, I didn't see any patch notes regarding what they fixed but as of right now on my modded server the plow and seeder both work! Zero issues. So far no looping exploding dirt animation from plow.

photo
1

Good to hear.