Main menu screen appears too small after loading

Arkantos TV-DE shared this bug 5 years ago
Need More Information

A few months ago I had the problem that I had two graphics cards (an Intel HD Graphics 530 and a Nvidia Geforce GTX 980M).

I told the game exe-file to use one card over another, it didn't work.

Both cards should have the latest drivers.

Now today after a longer while, I reinstalled the game (ME) and tried to play it with the Intel card deactiveated.

This time the game started and I could reached the mainmenu, but it wasn't displayed properly.

I could only see the bottom right corner of the game screen, at the top left side of my computer.

I tried to launch ME as administrator, later with deleted MedievalEngineers.cfg-file, but nothing works (also not the compatibility mode for Windows 7 and 8, I have Windows 10).

I hope you can help me, because I once really enjoyed playing ME. But now I can't.

Just a small note at the end. Before the first problem occured the main menu was displayed proberly, I could play the game, but then I got the message that I should change from Intel to Nvidia. I did so, but couldn't go back afterwards. And it never worked again.

Replies (5)


This has happened to some of our other players who had 3rd party display adapters installed such as iDisplay. Check display adapters in device manager.


I just checked it and there was only one display showed in the device manager, called: "PnP-Monitor (Standard)"

I don't think I ever installed a 3rd party display. There is Skype installed with which I can share my screen to a 3rd party, but this program wasn't activated then (and in my opinion shouldn't change the game experience).


It should look something like this with a GPU listed. It sounds like you may have looked at Monitors? If you are seeing pnp monitor for adapter then that may be a problem to look into.



I now know what the problem was.

ME isn't compatible with my Nvidia Geforce GTX 980M.

Because I just played the game with only my Intel graphics drive activated.

Thanks for the help either.


We have other players using GTX 980M GPUs so that shouldn't be the trouble. We have spent quite a bit of time trying to solve this for another player some time ago and the issue is that no matter what we do we're not able to replicate the problem. The cause most likely has to do with drivers or display settings. The only player who was able to solve the problem did it by reinstalling windows and all drivers. That tells us that it's a software issue so it should be solvable.

Knowing that the game runs on your Intel GPU eliminates many possible issues but it doesn't really find the source of the problem either. We still think it is most likely a 3rd party application or driver that is affecting it. It is possible, though less likely, that there are some bad settings in your NVIDIA drivers. You can try a clean installation if you want.

To clean install NVIDIA drivers

If you have tried to install from GeForce Experience the drivers will not be saved in a convenient place. We recommend downloading from using the manual search and running the .exe file to extract the files. Exit the installation when you reach the license agreement page.

  • Reboot - this is important
  • Open the NVIDIA file store at C:\NVIDIA\DisplayDriver\{VersionNumber}\{WindowsVersion}\International
  • Right click on setup.exe and choose Run as administrator***
  • Click Yes on the UAC prompt
  • Choose Custom (Advanced)
  • Check the clean installation box
  • Ensure that you are able to open the NVIDIA control panel and NVIDIA GeForce experience applications (if these applications won't open it indicates a failure of the installer)
  • ***It has been reported that this step has not resulted in the installer running with administrator privileges with the latest versions of NVIDIA installers on recent versions of Windows 10. However, launching the installer from an administrator command prompt is reported to work in those cases.

    Leave a Comment
    Attach a file