Dousing Torches or Forge leads to flickering light that follows player

Nicholas Carroll shared this bug 2 years ago
Submitted

Whenever I douse the forge or a torch, the glow effect doesn't go away, instead it starts to flicker very quickly. I stood back and had the forge run out of fuel while the forge occupied the lower right corner of my screen. When the forge ran out, the flicker started again, but rather than being centered around the player, it stayed in the same relative screen position, no matter which direction I looked or how far I moved away. It appears to be centered on the same area of my screen and distance from the player as the doused light source.

Reintroducing a light source, i.e. lighting a torch or relighting the forge causes the flicker to stop and the normal lighting effect to start around the player, but as soon as I take away that light source, a new flicker starts (verified by standing away, letting the forge die, getting a right side screen flicker, lighting a torch, dousing the torch, and seeing the flicker around my character rather than coming from the right).

I attempted modifying graphical settings (in game, no restart), which had a limited effect. I was originally playing with Shading set to extreme, and if I toggled shading to low, the flicker stopped, but started once I lit/doused a torch again. The switch from low back to extreme did not stop the flicker, but I was able to reliably switch from extreme back to low to force the flicker to stop.

I also cycled through AO, AA, and the various texture detail and draw distance options to no effect.

The flickering survived exiting to main menu and reloading the world. But was gone after exiting to desktop and restarting the game. However it started as soon as I doused a torch again.

The flickering also occurred on windowed, windowed fullscreen, and fullscreen, but did not survive the transition between the different display modes. I ran it in 1920x1080 in windowed mode to verify that it was not a problem with my ultrawide monitor (didn't seem likely).

Likewise, toggling vsync on and off would stop any initial flicker, but in both modes, dousing a torch led to flickering.

If I get a chance, I will disable SLI/gSync and update this bug with any results.


Specs in brief:

Core i9-7900x @ 3.3 GHz, 64 GB, 2xGTX 1080 Ti SLI

Alienware AW3418DW gSync monitor @ 110 Hz

Comments (3)

photo
1

Disabling SLI seemed to do the trick. I could not reproduce the flickering. Oddly enough, I could no longer reproduce the bug after I re-enabled SLI. False alarm?

Disabling gSync had no effect.

photo
1

Update to the update. After several minutes of playing with SLI re-enabled, the flickering started again when I doused a torch.

photo
1

SLI related. Good to know. We don't have any support for SLI in our render code, so anything that's not 100% compatible with standard DirectX 11.1 rendering will cause issues.