Claim Blocks are broken in 0.7

Dean Ascher shared this bug 6 months ago
In Progress

As the title says, they are totally useless now.

Either you cannot access them and are told that the area is "contested", even though it isn't, or other players can just build a claim block in your region and make your claim null and void.


Also other players are able to just spawn to your claim block, even if they are not a part of your house or have been given access: tonight on the Top Hat Engineers server players were able to spawn to anyone who had laid down a claim block, regardless of permissions.

Tested on both single player and multiplayer, the Claim blocks just don't work now.

Comments (8)

photo
1

Is any of the mods you run way out of date (you'll get a warning when connecting to server) ? I don't have any of those issues on my modded 0.7 server. Please check your server logs for bombing of errors.

photo
1

no mods, total vanilla.

photo
photo
1

we got this problem with no mods, mp survival

strangers can spawn at your claim block. the list of available spawns exists at the start of the game, and as said they all say 'contested area'. also backspace respawn does the old 200 foot sky jump and death fall... not on the bed but on the claim block. so somethin is up, will be glad for hotfixes!

photo
1

I also have these Claim Block problems.

photo
1

I can confirm that anyone can spawn at a claim block. They just recently seemed to start allowing/doing that. Wonder if it has to do with number of factions/houses.

photo
1

This is literally game breaking, please focus on this ahead of all other issues. A server doesnt function properly if people are able to just spawn wherever they like.

photo
1

I tried Claim blocks again yesterday and they worked perfectly. Thanx guys!

photo
2

I've gotten the same bug to. In a single player world of mine every time I restart the world the claim blocks re-contest the area and require taxes to be paid again.