Trying to load an old save game fails

Jan Chris shared this feedback 2 years ago

After some absent time from Space Engineers I would like to transfer some of my old designs into a new game.

I have tried to load old save games to make some blue prints of these old designs.

But every old save game is refused to be loaded. I guess the save game format has changed. But even an ingame conversion fails, although the game informs about the conversion attempt.

The error message mentions a wrong XML format, especially it doesn't like unsigned long values in the old save game.

The same error occurres if I try to load an old blue print from the steam work shop.

Maybe you already know about this problem and can give me a hint how to recover my old designs.

If needed I can supply the error log tomorrow ( writing this report on my smart phone )

Replies (2)


Here is the error log ...

Thread: 3 -> Exception occured: System.InvalidOperationException: There is an error in the XML document. ---> System.InvalidOperationException: The specified type was not recognized: name='unsignedLong', namespace='', at <Value xmlns=''>.

at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReader1.Read1278_PlayerId(Boolean checkType)

at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReader1.Read1279_EntryOfInt64PlayerId(Boolean checkType)

at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReader1.Read1280_Item(Boolean isNullable, Boolean checkType)

at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReader1.Read1351_MyObjectBuilder_Checkpoint(Boolean isNullable, Boolean checkType)

at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReader1.Read6401_MyObjectBuilder_Checkpoint()

at Microsoft.Xml.Serialization.GeneratedAssembly.MyObjectBuilder_CheckpointSerializer.Deserialize(XmlSerializationReader reader)

at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)

--- End of inner exception stack trace ---

at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)

at VRage.ObjectBuilders.MyObjectBuilderSerializer.DeserializeXML(Stream reader, MyObjectBuilder_Base& objectBuilder, Type builderType, Dictionary`2 typeOverrideMap)


Complete error log attached.

I don't know, if there will be more errors in the case this specific one is handled.


I'm sorry to hear that you're having trouble loading your old Space Engineers save games. I've done some research and found that this is a known issue, and the developers are working on a fix.

In the meantime, there are a few things you can try:

  1. Use a mod to load your old saves. There are a few mods available on the Steam Workshop that can help you load older save games. One popular mod is called "Save File Converter".
  2. Use a Roblox executor to load your old saves. Hydrogen Executor is a popular Roblox executor that can be used to load older save games. To do this, you will need to download and install Hydrogen Executor, then open the game and click on the "Executor" icon. From there, you can select the "Load Save Game" option and browse to your old save file.
  3. Contact the Space Engineers developers for help. If you're still having trouble loading your old saves, you can contact the Space Engineers developers for help. You can do this by submitting a support ticket on their website.

I hope this helps!

Additional notes:

Leave a Comment
Attach a file