This object is in archive! 

Scripts not working in Public test

Serogate shared this bug 19 months ago
Solved

I Started a new world with the Recent Public Test build. I noticed at even after enabling scripts in the world they just don't work for me. I can access the edit menu and choose a script however the script itself fails to load in to the programmable block and it defaults back to the placeholder text.

I tried reloading the world and simply starting it with just and empty no mod world but something is preventing the scrips from loading at all.

Comments (3)

photo
1

Hello, Engineer!


Thank you for your feedback. We weren't able to reproduce your issue. Can you please provide us with a script you are using and a save of your world?


Kind Regards

Keen Software House: QA Department

photo
1

I was trying to use Isy's Solar Alignment Script

https://steamcommunity.com/sharedfiles/filedetails/?id=699142028

I started the world with NPC mods like the Modular encounter spawner and plug-ins like Air traffic, plus the assertive cargo and bunkers plus reavers and corrupt npc. I have since removed all mods and still get the the same issue.

photo
1

I have since started a second world with No mods and getting the same result when trying to use script from the workshop. I zipped both save folders and attached them. The one named Beta test II is the one started with mod mods at all.

photo
1

After more testing, I found that manually copy and pasting the scripts in to the programmable block allows them to work, However I still cannot use script directly from the workshop in game.

photo
photo
1

Already fixed in upcoming version.