This object is in archive! 

[1.189.029][Major Bug] Inventory Weight changes depending on Inventory Size World Settings

Robb shared this bug 3 years ago
Solved

There is a major bug in the latest test branch (0.29) where the Inventory Size - World Settings actually multiplied the weight of every inventory.


The bug itself is gamebreaking as even the normal 3x settings would make ore 3x heavier and mining on any planet with gravity is heavily affected. A mining ship capable of holding 300.000 kg of ore could only handle 30.000 ore on a 10x server (that's 3x your persons inventory size... so flying there in person 3x is even better than trying to handle a flying mining ship on its verge of crashing into the ground)


I've tested it on Sunday with different World Settings in Singleplayer and Multiplayer.


Tested with iron ore / steel plates and stone.


Iron ore weight normal: 10000

Iron ore weight on 10x Inventory size is shown as 10.000kg in the container but the grid mass will get 100.000 kg instead of 10.000 kg.

Iron ore weight on 3x Inventory size is shown as 3.000 kg but the grid mass will be 30.000 kg higher.

Replies (4)

photo
1

Its a display issue only and has been reported before, unless they managed to fix it wrong. Did you actually fly a loaded ship and calculated against thrust?

Because my cargo ship lifted exactly as much as I expected it to with the new thruster buff and the undivided x3 inventory.

photo
1

I've tested it and it's not a display issue but the ships get heavier. You may not have noticed it on the 3x settings but on 10x it was too much. I had 16 small atmospheric thrusters and all it could lift was 23k iron so...


I already contacted Aragath and we'll see. I can ensure you, not only a display bug.

photo
1

x3 isn't the setting, its the default. The setting only affects player inventory now.

Depending on ship mass and location, 23k iron ore may be entirely appropriate.

photo
1

it is bugged and was confirmed to be one by a dev on discord, no need to discuss this further... seeing you post the same bug report as well makes it look unprofessional from your side

photo
1

You are entirely free to actually quote what was confirmed, considering your report claims something entirely different than mine did.

photo
photo
1

Hi, this was fixed.

Leave a Comment
 
Attach a file