This object is in archive! 

Gamepad settings conflict with Steam Input

ToxicBoxes shared this bug 19 months ago
Solved

During the public test, while attempting to use an Xbox One wireless controller, I encountered some issues related to Steam Controller Settings.

1. It's unclear which bindings are active. I initially didn't realize that the game was using the Steam bindings, not the game bindings. Because of this, I was confused when the controls in the help screen and the actual controls didn't match, the sensitivity setting had no effect, and the game still acted as if I was using a keyboard and mouse.

2. The game's settings menu will conflict with Steam. If I try to change "Controller Selection" in the game's settings, my controller appears as "Controller (XBOX 360 For Windows)". If I select that controller, the selection begins moving upwards (as if I was holding up on the controller). The controller will still be using the Steam bindings, so if I try to do anything, even with the keyboard or mouse, the game will rapidly stutter between keyboard and controller bindings (with the selection still being dragged to the top of the screen).

3. Simply clearing bindings through Steam will not fix this. Even with a blank control scheme, Steam will still hijack the controller's inputs, meaning the controller will then be completely non-functional in the game.

This issue can be resolved by disabling Steam Input for Space Engineers, but that involves entering Big Picture mode, so it's somewhat inconvenient and not very obvious. Once this has been done, the game will detect the controller as a "Bluetooth XINPUT compatible input device", and everything will work as intended.

Comments (4)

photo
1

This issue affects all games in my Steam library. =|

photo
1

Hi,

We investigated this issue, there is not much what we can do. You have to turn off Xbox gamepad simulation feature in the Steam client.

photo
1

How is this solved when this is still happening in 1.194?

Both the steam controller and the dualshock 3 behaves the same as the OP states. They both works perfectly in any other game supporting xbox controllers so clearly a problem with Space Engineers.

photo
1

Hi,

Turn off, xbox gamepad simulation in the Steam client. That's it.

photo
1

Doesn't work. Tried both in big picture mode and without.

photo