[1.191.108 SP/MP] Faction of visited Tradestation is still undiscovered

Takeshi shared this bug 56 days ago
Need More Information

Started Star System with Freands. Visited the first Tradestation on planet.

Beacon shows in white color.

In the list of (my) known factions are only SPRT and SPID.

Current Station is owned by SOPR.

Bought something, possible but no change.

Faction is still undiscovered.

--> reload the world fixed the problem and the faction is visible in the faction list.

Comments (5)

photo
1

Hi,

Thanks for the report

photo
1

Hi,

We can not reproduce this issue. Did you find any way how to do that?

photo
1

no because since i have read your request there was no public test.

Maybe i can only say it again, with the reload it was fixed and it occurs only on the first faction after creating a new world.

photo
1

I have a similar issue, only a reload does not resolve the problem. I have a Single Player Survival game that I've been playing for over a year. When the Economy update came out, I enabled the Economy feature, created a faction for myself, and started to check things out. I have discovered trading stations in space and on moons and have completed a few acquisition missions. But when I pull up the Faction menu, there are only "Undiscovered" factions showing, even though I have traded with three of them so far. I even approached a faction freighter to see if that would "discover". Approaching their ships and trading with them has not revealed any of these factions in the Faction menu.

photo
1

Follow Up: The factions I interact with continued to show "Undiscovered" in the Faction menu no matter how much I interacted with them. I was able to perform a "hack" fix by editing the Sandbox.sbc file and manually altering the DiscoveredFactions section (i.e. I added the Faction ID for each "undiscovered" faction). After doing this, when I loaded up the game, all of the factions are showing with the correct reputation numbers.

photo