Falling Through Planet Surface

Wojciech shared this bug 7 months ago
In Progress

after new patch my character on MP server fall under ground (textures) when I running and jumping. https://streamable.com/9aunn

Comments (21)

photo
2

https://pastebin.com/E7m69NUa - SpaceEngineers.log

photo
1

Hello,

can you please provide affected save file?

photo
1

Hi, i have the same problem since the update was released.

Files: log.txt
photo
1

Hello, i have the same problem

photo
1

Does anybody know how to reproduce it reliably?


Reload probably fixes the problem so the save files are useless. But could you try it?


Is it only in MP or also in SP?

photo
1

Hello, Engineers!


Thank you for contacting us! We haven't been able to reproduce this issue so far. Could you please help us by providing a save of your world? We will appreciate reliable reproduction steps and any additional information including:

  • Does this issue occur also in SP or only in MP?
  • Did you try reload the game?


Thank you!


Kind Regards

Keen Software House: QA Department

photo
1

My dedicated server is also experiencing this issue. We have wiped it removed mods. And regenerated a new world. The same issue happens. Hopefully it can be fixed. Its worse on Mars than anywhere else we have been. But been happening on the moon too. Thanks

photo
1

Been happening on our DS as well; I pasted Triton into our existing star system and we've been falling through it constantly. (Note that once you've fallen through you must respawn since you can't pass from the inside of the voxels back to the outside.) Savefille attached.

photo
1

Hello!


Thank you for your reply, however the attachment contains only a Sandbox text file. We need the whole save file. In case it's a DS save file: type %appdata% into your windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineersDedicated\Saves.

Please zip the file and attach it here. If you are having difficulty attaching files you can optionally use Google Drive. When sharing a google drive link please make sure it is set to be downloadable by anyone with the link.


Kind Regards

Keen Software House: QA Department

photo
1

Do you need the entire Saves\My.StarSystem directory tree? My DS hosting provider won't zip trees that large unfortunately, so if there's a subset of files that would help you please advise.

photo
photo
1

Here is my savefile.

It happens for me only in Multiplayer.

photo
1

Hello!


Thank you for your reply, however the attachment contains only a Sandbox text file. We need the whole save file. In case it's a DS save file: type %appdata% into your windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineersDedicated\Saves.

In case it's a lobby save file: type %appdata% into your windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers\Saves. There should be a folder with your SteamID and your saves.

Please zip the file and attach it here. If you are having difficulty attaching files you can optionally use Google Drive. When sharing a google drive link please make sure it is set to be downloadable by anyone with the link.


Kind Regards

Keen Software House: QA Department

photo
1

Hello Keen,


Have you got a save file for this issue yet? I can send you one. Please let me know. I have fallen through the world 5 times in the last hour.

photo
photo
1

It started to happen to me last night. Savegame here: https://1drv.ms/u/s!AnwljyIpzr3psk8qC46ckyaIm-d-?e=Bfe44X

Dedicated server, but only up to 2 players, most of the time 1. The engineer is falling through the surface just by running.

There is a medbay at Camp Alpha on Mars, and a future gold mine with a second medbay in place. problems occurred during mine excavation and since then nonstop.

photo
1

We couldn't resolve this. And gave up. Shut server down and are playing something else. A shame because we were having a great time.

photo
1

We are aware of this issue and we are actively working on a solution to this issue. Thank you for your patience.

photo
1

Recently got a server for this game and starting to fall through the planet a lot.

photo
photo
2

This has been a bug for a year and a half. It just got much worse with the frostbite update. Its also the all time top voted bug

https://support.keenswh.com/spaceengineers/general/topic/ghost-issue-falling-through-planetsblocks

photo
1

This happened occasionally before the frostbite update but of late it happens a few times a day. I saw the announcement about Windows 7 users. I'm running the latest version of Windows 10 and all drivers are updated.


Specs:


Mobo: MSI H77MA-G43

CPU: Intel Core i5 3330 @ 3.00GHz

Memory: 8GB DDR3 memory

GPU: MSI Twin Frozr Geforce 950 OC edition 2GB Memory

photo
1

Adding a +1 here. I'm running a dedicated server and I am getting reports that a few of my players are seeing the issue more regularly in the last 2 weeks. Not all of my players are though, and I myself have never fallen through.


I've recommended everyone play "the floor is lava" game for now and distributed extra hydrogen bottles to everyone.


Thank you to the Keen engineers for looking into this.

photo
1

Guys, it should be fixed now. Please update your game (194.2) and let us know.

photo
1

Just had this happen to me in MP - was traveling around 100 kph on a large, flat ice lake. No lag, not hiccup, just... suddenly my rover and I fell through the ground. Currently about halfway to the other side of the planet...

photo
1

Just happened to me - 4 times, so far today, once with my rover. On Earth. Lost my Rover needless to say not to mention, H2 bottles plus upgraded tools. Most of the time I have to kill myself via high speed collision. With my Rover today I decided to stay along with the ride. At just over 60k, I ran into a asteroid. A hollow one with no exit so Hari-Kari again. Except for my Rover incident, it happens most when I am mining underground.

Love the game but may have to take a break if not fixed soon.

photo
1

there is a certain area in my world where it happens. It's like a big portal on the cliff in the easy start world. it is the only place where it happens and after reloads and reboots it is still there in the same place. The hole was big enough I could fit significantly large small grid ships through and actually fly them under the world the same as above. the only difference being that 3rd person was not available. it actually kinda cool because I had a few friends and I formed a fleet and did an underground raid and rammed the wall of an underground base and the ships popped through. since it is the only place it happens we are invincible when in the ground. also, it seems that bullets coming from inside the earth can phase outside without a problem, so we were able to fly up under cars and shred them from inside. for those concerned this is not a public server, just my worlds that my friends and I mess around in and shoot our own bases. I would eventually make this a DS but if this is a problem I would have to just stay in space. bit of a bummer for me though because I take half of my time in this game driving mechs and cars.

photo
1

i would give a video but the max size is too small for me to upload

photo
1

We just fell though planet on official FR2 server me my friend and our HUGE car fell down and its not the first time this happend to us but first time with this HUGE car we spend a lot of time making it...

photo
1