Series X - Missing paid DLC content

Bae Butler shared this bug 5 months ago
Need More Information

Since upgrading to the XBOX Series X and installing the game and content to the new SSD, I have been unable to see/access my pre-order content.

Comments (5)

photo
1

Thank you for contacting Keen Software House.


If you could please contact Support@Keenswh.com so that we can collect more information.

photo
1

I need contact info to do so

photo
photo
1

Hello,

what content exactly are you missing? Did you check if all DLCs are correctly installed?

Thank you.

Kind regards,

Keen Software House: QA Department

photo
1

Sorry for the late reply, the ONLY thing I am missing is the pre-order DLC content. I have the 10.1mb “Space Engineers: Pre-order Pack” installed on my XBOX Series X but it no longer appears in the character customisation menu for selection.


To specify, NONE of the suits work. The Veteran, The Pilot, The MK2, none of them appear in my character customisation menus since migrating to the new console and I traded in my OneX for the Series X so cannot confirm wether they still work on that system or not.

photo
photo
1

Hey I am missing pre order content suits next gen from what my mate is telling me 

On Mon, Jan 4, 2021 at 6:49 AM <support@keenswh.com> wrote:

photo
1

This happened to someone else aswell. Idk what xbox he was using but all his dlc's were locked as if he didn't buy them. When he tried pasting in a ship it said he didn't have the dlc for it and when he went into Microsoft store it said already installed.


I haven't experienced this problem myself though

photo
1

Thank you for the info. There is even multiple threads on this topic, however in most of them we are still trying to get the information on what exactly are players missing and which DLCs they own.

Kind regards,

Keen Software House: QA Department

photo
1

Just to confirm I am still only missing my “Space Engineers: Pre-order pack” and ie. all content/cosmetics eg. Veteran Suit, Pilot Suit, Tech suit etc.


All other DLCs (all of which I own) are working fine.

photo
photo
1

Hello Engineers,

We tried to reproduce the issue on multiple accounts and preorder skins always appeared practically immediately after installing Pre-order content pack. If you are still affected by the issue, could you please try to completely remove SE from your console and install it again?


Any additional info would be greatly appreciated.


Thank you.

Kind regards,

Keen Software House: QA Department