Unstable GPS list

domingo shared this bug 6 months ago
Reported – Awaiting fix

I've created quite a long list of GPS coordinates.

All planets, some POIs and all asteroids I mapped in about 30km radius.

After a longer time playing I noticed that I am missing some of the GPS coordinates I've created first (planets mostly).

My GPS list is now about 120 entries long.

Replies (1)

photo
1

Hello, domingo!

Sorry to hear you're experiencing issues. Could you please supply a copy of the world in which you are having these issues?

Please upload the world to mod.io and share a link in this thread.

Kind Regards,

Laura, QA Department

photo
1

Hello Engineer,


This save contains mods so unfortunately we cannot use it. Are you having those issues on worlds without mods? It is entirely possible this issue was caused by one or multiple mods.


Thank you.


Kind regards,


Keen Software House: QA Department

photo
1

There must be NO mod at all ?


I have to admit I think I played vanilla (no mod) maybe only first few starting hours long ago.

However I don't use a lot of mods.

Or is it enough to have mods without code (no .cs content, thus only .sbc files) ?

Can be this same or similar problem as the issue with positions slowly drifting over the world lifecycle ?

The world has currently unknown object appearing few meters from their gps marker.

It is probably connected to save/load function.

photo
1

Hello Engineer,

For us to use the save we would need it to be completely free of mods, yes. However, we're aware of the issue with the unknown containers you've described, it's already been reported to our internal system. Are you having any other GPS-related issues on worlds without mods?

Thank you.


Kind regards,


Keen Software House: QA Department

photo
1

I've started new game with all mods that change code (.cs content) removed.

However I kept some that changes only game definitions (.scb content) - I suppose they are quite safe in the scope of this issue (though I miss BuildInfo a lot).

I will write here if I encounter the problem.

I've already encountered unknown containers markers few meters off for some, though it is not the subject of this report.

Or is it imperative to really have no mods at all ?

For me they increase playability a lot :-)

photo
1

I've encountered again this issue.

I lost GPS to my base when I was adding several GPS markers via clipboard and/or enabling/disabling a lot of them.

I will try to notice and reproduce the exact conditions

photo
1

Seems I've placed this in the wrong section.

The issue I have is in PC, not on the XBox.

photo
1

I've reproduced it reliably.

The issue is linked to the unknow signal source GPS, when it is not spawned naturally but via blueprint.

Reproduction steps:

- create new game (no idea if it must have unknown signals enabled if going for creative mode)

- create some GPS marker

- project and weld the button from blueprinted unknown signal source (there are some on workshop or blueprint one when it appears)

- click the button

- the created GPS marker should disappear

=> if the unknown signal source is missing it's own GPS marker, it will remove other (however this does not work with regular sources that have their GPS marker deleted by user in the GPS list)


There are a lot of details, scenarios I didn't tested, however this should be enough.

- like whether it can happen only once per game load (that's the theory because I didn't lost two markers when I welded two, only one)

photo
2

Hello Engineer,


We've managed to partially reproduce the issue you're describing. It's been added to our internal system.


Thank you.


Kind regards,


Keen Software House: QA Department

photo
Leave a Comment
 
Attach a file