Workshop unable to publish blueprint

Erling Nygård shared this bug 16 months ago


When I try to publish a new blueprint it fails.

I've found out why, the image taken is too big and steam won't allow it.

When I compress the image to under 1MB it works.

Comments (3)


Hello, Engineer!

Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.

We really appreciate your patience.

Kind Regards

Keen Software House: QA Department


Current the game saves blueprint pictures as .PNG files which are as large as 2 MB. Steam has recently lowered the file size you are allowed to upload to the Steam Workshop form 2 MB to 1 MB. While we currently have a work around of manually going into the blueprint folder and converting the file from .PNG to .JPEG, which dramatically reduces the file size, allowing you to upload the blueprint to the Steam Workshop.

Either we need the blueprint picture file size reduced or we need all blueprint to have they screenshots take in JPEG.

I would recommend that all new screenshots be in JPEG, but leave the ability ingame to view the old PNG files as backwards compatibility.


changing to jpeg doesnt help for me either, if i delete the thumbnail before i publish, it uploads to WS but with no thumbnail, which deletes the purpose to share on the WS, yes every thumbnail i try is below 1MB, i even tried compressing it 1kb, still get "failed to upload" error, i check game integrity files, all fine, i even reinstalled, still cant upload without failed to upload error, i have 30+ frontpage builds, so its not like im a noob to uploads to the very salty over this, and it seems im not the only one with this issue