Surround sound not working with positional sound sources

Arttu Mahlakaarto shared this bug 3 months ago
Reported – Awaiting fix

First of all, I Know there are existing tickets about this issue, but most of them are marked as outdated, wontfix etc etc, because the issue was not reproduced by keen, im here to give all the details needed to reproduce the issue


I was not able to attach the video as it is bigger than 64MB,

Video here: https://streamable.com/t2rtca


The bug:

When using a audio output device which has surround sound (5.1(6 channels) or 7.1(8 channels)), all sounds played using a soundblock are broken, such as that no matter where the player is in relation to the soundblock, it will always sound like its coming from right next to the players right ear, (as long as the player is in range of the sound)

there is a quiet sound also coming from the left side speaker.


If I set the game to output audio to a 2 channel (Stereo) output, the sound works normally.


This issue happens with both Stock and Modded soundblock sounds, but interestingly, if the sound being played has a bitrate other than the expected 44.1kHz, the sound sounds like its playing inside the characters head.


STEPS TO REPRODUCE (on any system):

These steps work even if you don't have a surround sound headset or home theater.


These steps are split into 2 parts. the first one is how to setup a "Virtual" 7.1 channel surround audio input/output device, the second is how to reproduce the bug in game

1. Install "Virtual Audio Cable trial" by muzychenko,

1b. Change the default output and input device to something other than "Virtual Audio Cable"

2. After installing, open the VAC control panel (As a administrator) and change the following settings: "Max NC" set to 8, then click the "Set" button next to it, then, under "Format Range" set the 2 boxes next to "NC" both to 8.

3. Click the "Restart" button in the left side of the window, under Max NC, then click the "Set" button on the right side of the window (Not the one next to "Max NC" )

4. Change the default audio output device to "Virtual Audio Cable"


Now when you open the game, look at the "Signal levels" column in the VAC control panel, and you should see little red bars indicating the sound being outputted to each of the 8 channels

Leave the VAC control panel window open, and open the game

Steps to reproduce ingame:

1. Create a grid with a sound block

2. Play any of the sounds from the sound block (Preferably on a loop)

3. Move around the sound block and notice how the sound is always loudest on the Right channel


If you want to hear the sound while playing, open windows audio settings, go to "Recording" tab, select the "Virtual audio cable" and enable "Listen to this device" and from the dropdown, select your normal audio output device, such as a headset

Best Answer
photo

Hello, Arttu!

Thank you for the information. As I was able to reproduce the issue, I have reported this internally. I really appreciate your steps and even the image for helping with them :)

Kind Regards

Laura, QA Department

Replies (2)

photo
2

Hello, Arttu!

Thank you for such a comprehensive guide with this and I'm sorry you're experiencing issues. I have been testing your method and admit I have not used this software before. I have followed your steps and have been monitoring sounds. I can only see with red bars (signal levels) the sound really only coming through on the left compared to the right that you mentioned. (This isn't a bad thing, I just can't work out why we would have different results.) I also find that moving very far away from the sound, the red lines are still showing even though if I switch back to my own source, I cannot hear the music. This seems quite odd to me. Due to this, I can't say that I have reproduced the issue thus far. If you have any further information, it would be a great help as I would like to reproduce it and get it reported. Also, I notice in your video you have a bit more of a comprehensive bar showing the sound, is this from the program?

Kind Regards

Laura, QA Department.

photo
1

Hi Laura,

I have noticed that for some people the sound does come from the left side instead of the right side with this bug.

One tip on having a little more precise meters on the individual audio channels is to use OBS software and configure it to record the virtual audio input device, as that way OBS will show precise level meters for each channel.

OBS is what is used in the video as well

photo
2

Hello, Arttu!

Thank you for the information and clarification for OBS :)

I notice in your previous comment on an older thread you mention you changed your motherboard. Am I correct in saying this only started happening after you changed this? I also have an Asus ROG which should be useful in this instance.

Kind Regards

Laura, QA Department

photo
1

I have had 2 different Asus ROG Motherboard models with the same issue, I have not been able to test if the issue is present on other motherboards.

Some more hardware info on current system:

ProcessorAMD Ryzen 9 3900 12-Core Processor, 3100 Mhz, 12 Core(s), 24 Logical Processor(s)

Motherboard ROG STRIX B450-F GAMING

photo
photo
2

Hello, Arttu!

Thank you for the information. As I was able to reproduce the issue, I have reported this internally. I really appreciate your steps and even the image for helping with them :)

Kind Regards

Laura, QA Department

Leave a Comment
 
Attach a file