Workshop Page Infinite Loading Loop when Offline

KaiiKiller shared this feedback 15 months ago
Submitted

Hi, I usually game with Steam in offline mode, and I clicked the workshop page by accident and there is an infinite loading loop when in offline mode for the Workshop page.


Also, I can no longer load my offline save that has a mod in it, it says please set world to offline mode when the save is set to offline already.... in the past if I loaded the world once to get the mod to load in, then saved > exited > then started in offline mode I could then load the world with the mod in offline mode.

Comments (5)

photo
1

I meant to post this in bug section but it appeared in idea section.

photo
1

The bug is still there. What is weird, is that now it's in infinite loop while I'm online too.

And it refused to load my local vanilla blueprints while offline as well.

Something is quite fucked up with offline game.

photo
1

I have since uninstalled Space Engineers, with this bug present I have no reason to even try running the game.

photo
1

When you play offline mode, Steam disables cloud/mp access. If you want to play a world with mods offline, you need to download the mod and save it in your manual folder first so SE has something to use. I've never had this issue myself, but I'm sure I've read the solution before so google might help you.


The online loop I can't speak to.

photo
1

I have been playing SE for years in offline mode I know how it should function.

If you could test it for me that would be cool, load a mod into a world, save the world, exit the game, disconnect from internet, start steam in offline mode, start SE, load the world with the mod in it, then if it works that would be nice.

photo
1

That's not how you do it. It's much more inconvenient which is why I voted for this.

https://www.reddit.com/r/spaceengineers/comments/916cn1/can_you_use_mods_offline/

Alfie has good directions there although Steam may have changed it's download folder location and made it separate from your manual extract location.

photo
1

I've always done it like that and it had worked up until one of the more recent updates which stopped me from loading my world, it only had one mod *shrugs*


I'll bookmark your linked post to try in the future, whenever the survival update gets released.

photo