Warheads do not damage environment

Jack Bishop shared this bug 16 months ago
Need More Information

I’m official keen sever (#4) I have noticed that warheads will not damage surrounding environment after an explosion, however will still damage ships. This was tested a few times by myself and couple others and have come to the conclusion that this is a major issue as warheads are very useful as a way of using controlled explosions to either mine or clear space for a base

Comments (2)

photo
1

Hello,

Does it still happen to you? I wasn't able to reproduce it.


Any additional information would be greatly appreciated!

Thank you.Kind Regards

Keen Software House: QA Department

photo
2

Small grid warheads do zero voxel damage, but do still damage grids. This was in a locally hosted game, as witnessed here:

https://youtu.be/zwAgbxk2vSc?t=4987

watch for a couple minutes- warheads built by hand and ones placed with creative mode tools simply detonate and no voxel damage occurs.

Haven't tested large warheads or on Dedicated Servers, but I get the feeling it warrants further investigating and fixing if other people are reporting it.

photo
1

Hello,

Try turning off "Adaptive Simulation Quality" in first tab when creating dedicated server. This option is trying to preserve performance when simulation speed starts to drop.

I hope it helps.


Kind Regards

Keen Software House: QA Department

photo
1

I've just exited a survival game. I'm playing with the Escape From Mars mod in single player survival. Neither warheads nor missiles damage the terrain. I can upload some video later when I get time.

photo
1

Delphic sector Steam community, MCN faction on the official server UK#7. We have the same problem on Mars, warheads don't do voxal damage on planets. If warheads where fixed we would then not have to worry about our second problem below and make planets viable to stay.

The second problem which we feel is worse is when you use right mouse button with large drill blocks to clear terrain, new strange black terrain sometimes appears at the drilling area.

This new black terrain can spawn inside your vehicle and cause major damage and has to be re-mined out to continue. This bug is quite easy to replicate. As of this moment end game mining is too dangerous on Mars, making the Mars planet almost pointless. Look for Orticus if you need a demo (not tested on other planets).

photo
1

I have the same problem on the alien planet when i tried to blow up a hole. it still damage Grids, but not terrain.

photo
1

On Keen CA #2 this is happening, multiple attempts and different players

please assist

photo
1

Keen UK#7, warheads doesn't affect voxel at all, it acts as if disabled entirely.


i've been experimenting on my dedicated server for the past two hours, fiddling with all settings. testing as admin/player.


so conclusion:


1. Fresh server, low runtime - the problem does not occur on.

2. a single player, low runtime - no problem

3. Not admin/player role - related.


The only thing i really cannot test at the moment, is a high uptime, multiple players to check what i am suspecting it might be:


Trash removal:


Voxel age

Distance voxel from grid

Distance voxel from player

Voxel reverting enabled

OR desync - which has a confirmed presence on all official servers.


I'm suspecting, if there might be a slight behavior causing the voxel to base it's age/distance from other players rather then the present player, causing age to be greater then age and reverting upon detonation. Now taking desync into consideration as well, it assumes there are no players nearby due to desync and voila, revert.. but then again, this might just be a theory, i cannot reproduce this at this point.


A few additional notes:

The Voxel behavior regarding reverting and age should be better explained, age is that not how long before actual reverting, i set mine to 1 minute and 1000m distance. flew 2km off and came back 15 minutes later. nothing was reverted...


The GUI for dedicated server has some dodgy behavior when it comes to saving/loading and not agreeing with experimental mode enabled, it warns and reverts instead of just saying "your current state requires experimental mode" and aggressively forces settings on/off.


All in all the tooltips on the dedicated server interface is rather lacking and/or very short and not so informative. if you then take the auto-reverting of settings into consideration it makes if somewhat annoying to configure and in this case - test settings for bugs.

photo
photo
1

I have the same problem. Single player environment on Mars. Warheads do no damage.