Voxels Respawning During mining

Sven Rijneker shared this bug 5 months ago
Solved

While mining an Ice lake (no stone in sight) some of the voxels respawned as Stone and broke my large grid miner (spectacularly). This is breaking all of our miners currently.

Playing Multiplayer "Never Surrender" scenario, hosted by my friend in Holland, I am in the UK

Our ping is on average 40 - 50. I have included a recording of the voxels respawning.

Even the Host sees these respawn in and mining them over and over just gives us unlimited stone... which is very unhandy! We want the ice but can't drill further

Comments (31)

photo
2

Same thing here. Currently removing part of a mountainside with voxel hands and some huge, triangular shaped chunks are left behind. I can delete them in creative all the way until their last piece and then, when that's gone the whole lump respawns again. Never had this problem before.

photo
1

I have the same problem only on the Europa moon. And the ston respawned twice. Once to tear just a part of my rig, then it spawned through it so quite an explosin was following.

Few screenshots: After first respawn, After second.

photo
1

The coordinates where this had happened in my case are: x=2272969.31, y=4650877.69, z=-5342655.55. The cross-section of respawned material seems aproximatelly triangular with steadily varying size of side. And mining it yields nothing. Vannila game with no mods. Offline world in my PC.

photo
photo
1

I am currently having this problem as well, I have a large mining ship and I am currently on mars. Each time I try to mine a triangle voxel respawns, This is game breaking for me since it means I can no longer mine as it happens every time I try to. So I am forced to not play until it is fixed...

photo
1

Having exactly the same problem, Any help would be great.

photo
2

No matter where i mine this happens every single time.... I can't mine any resources! i cant build anything anymore. Does not happen in single player (at least so far...) only in the multiplayer world me and me friend play together, only 2 of us.


At first i thought it was becouse i was using a drill that was far to large, so i reduced the size to 5 large grid drills and it still happens at every single location i mine! This is stupid

Edit : This only happens near the surface, once you get further down it has not happened so far

photo
1

So far i have only found one way to deal with this bug.

Use your miner as normal until it explodes due to voxels re-appearing inside your ship/Station miner (i use stations to do my mining, like outposts)

I map out the culprit voxel which is almost always in a triangular shape, manually mine out further below it so i can push my piston past it so i no longer mine that part as i am further down into the planet.

photo
2

https://youtu.be/g67M5yXMxrk

Video of this issue happening but I can't get rid of it at all

photo
1

i have the same bug earth creative single player

ice lake stone keeps spawning on the surface smashing my drills in big chunks or little squares the same size as my hands

photo
1

same shit

photo
2

I have the same problem in snowfields on mars. They kill my ships and when I drill them down, they will appear again immediately.

photo
1

This game has so many bugs after the update that it becomes unplayable for me. 1578 hours in 1 year. I'll wait a year for it to improve at this moment, thumb down

photo
1

Same problem for me. I tried 3 drilling spots, can't create a single one, my drills explode after 1 or 2 meters deep. I didn't find this post at the moment, I put some more images here : https://support.keenswh.com/spaceengineers/general/topic/hard-ghost-voxel-respawning-while-drilling-breaking-the-drills#comment-13801

photo
1

same shit

photo
1

I've had this bug in single player in the Never Surrender scenario.

photo
1

I can confirm this happening in the Never Surrender scenario as well as the Star System custom game.

I lost 3 ships on the same chunk because of that.

photo
1

Hello, Engineers!


Unfortunately I wasn't able to reproduce your issue.. Any of you guys have a world where is this issue constantly happening after reloading? Or reloading actually temporary fixes the issue?


If anyone have a world like this please upload it here!


Thank you for cooperation and sorry for any inconvenience.


Kind Regards

Keen Software House QA Department

photo
1

Hey Ales any advice on the GPU Crash for 189.044 ? Thank you very much.

photo
2

I think I have a save. I'll put it on dropbox if I find one and give you the link (not sure if I can throw it on the forum here because of the size), I had the problem on different worlds.

photo
2

Testing to send it on the forum.

I saved my character just in front of one such voxel. Another one is in the second hole near the first one. Seems to appear only near the surface, not underground.

More screenshots of what's happening here : https://support.keenswh.com/spaceengineers/general/topic/hard-ghost-voxel-respawning-while-drilling-breaking-the-drills

photo
6

Hi Asree,


thank you very much for the world you posted.


We were able to reproduce the issue and will will work on fixing it.


Thanks for cooperation.


Kind Regards

Keen Software House: QA Department

photo
photo
4

Same bug here, playing on Solar system, multiplayer. Build a drilling rig out on an ice lake, and set it going - and watched as this big triangular voxel pops in to being at surface level, almost every time the drill passes that volume of space. Interestingly, stopping the drill arm when it was turned away from the voxel, and leaving it for 2 hours, the voxel did not spawn; but, when the drill is in that space, the voxel pops up (and often immediately respawns when you remove the last part of it). The voxel in question returns no ores or stone, and seems more prone to leaving tiny floating chunks behind than normal terrain is. about half the time, it spawns inside the drills themselves.

photo
2

I have the same issue, and it made my game unplayable since I have spent many hours with my girlfriend building a giant miner ship and set up timer blocks to make it mine automatically.

I love the game but like this there is no point for me to play until this will get fixed.


I have a save file what I am going to post to help the developement team out with some samples. I know right that this world has mods, not just one... but believe me I have tried to turn them off and turn them on one by one to see if any of them are causing the issue but it seems like there is something else causing this not mods. Also happened to me in vanilla world.


In my save file( hopefully the zip wont get corrupted) soon as you will load the game you will see the drill ship in action, I have occoured the respawning rock issue and forced some pistons to reverse so It wont explode...again so you will see the drills moving upwards away from the mining site but just a few seconds on the way up you will see voxels reappearing again... if you help out the drill with hand drill not to explode and let it dive in(it is diving very slowly to bee safe,sigh) you will occour this problem again and again... it is terrible,


Thanks for the work guys, please fix your game so people will love to play it in the future, including me.


https://drive.google.com/file/d/1sk-lSmN9KbxbTjpSlY2e3QiZDWNkECJn/view?usp=sharing

(can not attach file because it is larger than 20 mb so here is a google drive link)


Sincerely,

Tom

photo
1

This is happening for me as well. bI am not sure if this is even typing as all I see is w white in the etxt box

photo
1

also happend on my singleplayer solar system. reproduceble on any surface voxels like moon, europa, earth. to work around you can dig under the buggy voxel and remove it with the handrill. I also can provide a savefile if needed

photo
1

This was during my Tunnel drilling Project for my Monorail Trak.Stones are Respwning very quickly.

photo
5

Hi guys,

fix is a part of next Minor update. We want to release it at the end of this month.

Thanks for your reports.

Kind Regards

Keen Software House: QA Department

photo
1

Thanks dude. I hope it works!

photo
photo
1

I have the same bug when I drill in an ice lake, this happened to me when I played in survival and creative in the Star System scenario.

I hope that the team can solve this in the next updates.

Thanks in advance.

photo
1

Fixed in version 1.190.1.