Using merge block deletes groups

kittle shared this bug 10 months ago
Solved

I have a ship with detachable sections via merge blocks. Each section is designed to detach and fly on its own. so it has flight seats and groups for thrusters, welders, drills and other things.

but whenever I detach a section, some or all of its groups are deleted and their respective icons show up as the grey 'broken' icon on flight seats.

Comments (4)

photo
1

Hello,


Could you please provide us with more information regarding the issue you reported? To report a bug into

our system it is necessary to have reliable steps to reproduce in order for programmers to fix it.


Any additional information would be greatly appreciated!


Thank you.


Kind Regards

Keen Software House: QA Department

photo
1

1) build 2 ships (cockpit, thruster, gyro, power, etc). each with 1 merge block

2) Create a group in both ships (make sure they are different names) - I suggest using the thrusters. Place the an icon on the control station's toolbar to toggle thrusters on/off

3) merge the ships together. Exit cockpit and get back in. Fly around a little bit.

4) un-merge the ships -- groups are gone, and the icons in control station toolbar show as broken/greyed out.

I have not tried this in singleplayer, but it happens 100% of the time on the dedicated server I play on.

photo
1

Reproduced and reported.

Thank you!


Kind Regards

Keen Software House: QA Department

photo
1

i have the same bug tried everything

photo