Unpowered connector still works

CptSavarus shared this bug 15 months ago
Need More Information

Noticed a bug in my most recent survival game.

I have one ship in the world with one connector on it and a pair of assemblers.

Setting either of the assemblers to disassemble parts will cause them to send the resulting ingots to the connector - even though the connector is turned off and there's a direct conveyor path to a cargo container with available capacity.

I'm also able to access the cargo container inventory & remove items from the container via the connector - again, while the connector is turned off.

The connector is acting as if it's set to "collect all", even though it's not.

Can publish & link a world file or blueprint if required.

My game version is current.

The world I'm playing in is a brand new world still in early game and does not use any mods.

Have never seen this bug before in any other world.

Have not yet tested a blueprint of this ship in any other worlds.

Have not yet tested other ships to see if the problem is universal.

I do not know steps to reproduce, as I have no idea what caused it. Could possibly be linked with a Reactor / Solar Panel bug that I've reported separately. Both bugs seemed to first appear around the same time.

Comments (2)

photo
1

What you're experiencing I can best describe is that Connectors inventory is considered a cargo container inventory. When cargo is shuffled around the logic used is to send it to the first available valid cargo container in the line. If a connector is before the cargo, because it is equal to cargos, it will take stuff first.


I tested this and found connectors in SP were not vacuuming materials up as if collect all was on. They are not given materials if another valid cargo container is closer in the line. Knowing this, I would not mind 'use conveyor'as a connector's terminal option similar to many other blocks.

photo
2

Interesting. That does make sense.

If that's the case then I agree, a "use conveyor" toggle would be useful.

Personally though I'd prefer to see blocks get prioritised by type rather than location - cargo containers should get filled first & connectors only if there's no available space in a container.

Apart from anything, on a ship with multiple connectors you can end up having cargo spread around all over the place, which can make inventory management really confusing.


Doesn't explain how it's still possible to access cargo in another container through the connector when it's powered off though. It's like the on / off toggle is being ignored for the purpose of moving cargo but not for the purpose of connecting to another connector. When off the light still goes red & nothing can be locked to it - and as I say, it comes on like a bug. You can play for a while with the connector behaving normally, then all of a sudden it'll decide to let you access cargo from elsewhere.

photo
1

You're right about the on/off thing. The only block that respects Block Power on/off for conveyance is the sorter block I think. Even then sorters behave oddly when it comes to gases. Other than that the conveyor system is independent of the blocks power setting. You can shut a Refinery off and still fill it with ore manually for example.

photo
photo
1

Hello Engineer!


Conveyor system only needs the grid to be powered. Individual on/off settings of each block are not considered.

Except for Sorter block, where its only purpose is to (dis)allow blocks through. It is a kind of inconsistency, but might be a design issue, not a bug per se.


The second issue that you mentioned is where a connector is allowing connection to other grid's inventories despite being turned off and therfore not locked.

Am I correct in that assumption?


I am changing status of this ticket to Need More Information. Please provide additional relevant information (blueprint, save, log, screenshot, video and most importantly steps to reproduce). Ticket will automatically close after around two weeks when no new relevant information is given.


Thank you for your cooperation and have a nice day.

photo
1

Thankyou Keen for your response. Apologies for the delay in mine.

Here is a link to the world file published on the Steam workshop.

No mods are used. It's set up & ready for you to test.

I've also included some screenshots which you can find on the workshop page, as well as a description of what's going on & how to reproduce (a simple matter of accessing the cargo inventory through the connector)...https://steamcommunity.com/sharedfiles/filedetails/?id=1581488778


I've never had to submit a log before & am unsure how to do so. Please let me know where to find the log so I can post it.

Will be happy to provide any further information you require on request. Many thanks.

photo