Inventrory running out of sync

Krug shared this bug 2 months ago
Considered

Hello everyone.

I just talked to Inflex and he adviced me to put this up here so here we go:


I foudn this problem while playing on a multi-player-server.

Here is how I found it to happen.

I went to the assembler and queued 1000 stealplates.

There was plenty of Iron so it happyly went at it.

everythink is fine untill you attempt to get you frechly produced stuff out of the assembler.

I went to a cargo-container wish has an interface with the assembler and pulled the suff out.

It then apears in my Inventory and still inside the Assembler.

The Inventory of the Assembler does not update its contents after that.

The mass updates however and work is still carryed out. you just don´t get to see the results and can´t access them anymore.

I sure hope this Information will help you find the source of the problem.

If there are any more questions feal free to contakt me by mail or on Discord. My name on Discord is Tesedar.

I´ll close for now and wish you all the best in keeping up the great work you guys do.

Comments (3)

photo
1

I have had this happen several times in different ways that the screens will not be synced and will not show different changes, for example I switch what I am producing but it continues to show the same ingots being taken as before and the item I switch to for production doesnt use those ingots.

photo
1

I have experienced this bug not only with the Assembler but with every Inventory, even the Players'. Sometimes I cant store items nor get them out