Inventory Bug on private server

Sam C. shared this bug 9 months ago
Considered

My friend and I recently started up a private server I am hosting on my own computer. Everything was working fine for a few hours until my friend suddenly couldn't move inventory out of the base's cargo system. Reloading both PCs would temporarily solve the problem but it would come back within 10 mins. The following week when we met up again it was a similar scenario, worked fine for a few hours then it would quit working. The cargo system has no sorters to block item travel and he couldn't even pull inventory by directly interacting with the inventory in containing what he needed.


The first go around we had Isy's Inventory Manager and Solar alignment scripts running. The second time I added in Easy Inventory. My friend could still get inventory with Easy Inventory once the bug hit but could not directly remove items through the inventory screen. He could, however, store items from his inventory.


I convinced him to get the game with the upcoming Survival Overhaul and we have a lot of plans for when it goes live, but this bug could really put a damper on things.


Thank you for your time.

Comments (2)

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

So, me and 3 of my friends have started a new survival save on my SE DS yesterday.

Since this new save, I've been seeing 2 weird issues: First we're all experiencing our inventory to be "bugged" after x-time (random). It seems like our inventory is visually not updating and it's also affecting gameplay as we can't use components anymore. Secondly, the CPU usage is now 13% higher than my other save game, which makes no sense at all with it being a brand new game with nothing in the world.

The first issue is resolved by logging out and re-logging into the server. The second is causing random lag.

My first issue matches this bug.