Dedicated Server Manager occasionally does not allow main game to start

Kindjal shared this bug 14 months ago
Considered

Ran into an interesting issue with running a dedicated server on the same PC I play from. Currently I have to start Space Engineers then run the server manager as there are instances where the server manager, for some reason, is interpreted by Steam as the actual game itself and does not allow multiple instances to occur.


This leads to being unable to launch the game without shutting down the server. Sometimes it can be shut down and I can get the game going again. Other times there are people actively doing activities in-game that shouldn't be interrupted.


There are not any instances of SE running (just the manager) and when closing the manager via task manager Steam immediately removes the "Running" tag.

Comments (8)

photo
1

Just noticed while toying with the server manager: When you select Connect To Steam it shows in Steam that Space Engineers is running. Even when you logout via that same dropdown Steam still thinks that SE is running.

photo
1

don't know if it is related, but my server is not showing up anymore in steam. looked into the log and found. currently the server is logging off steam and therefor is cannot be reached anymore

2018-07-24 16:23:29.363 - Thread:   6 ->  Game ready... 
2018-07-24 16:24:15.587 - Thread:   6 ->  Exiting..
2018-07-24 16:24:15.587 - Thread:   6 ->  Used namespaces in scripts:
2018-07-24 16:24:15.587 - Thread:   6 ->  MySession::Unload START
2018-07-24 16:24:15.587 - Thread:   6 ->  AutoSaveInMinutes: 9
2018-07-24 16:24:15.587 - Thread:   6 ->  MySandboxGame.IsDedicated: True
2018-07-24 16:24:15.587 - Thread:   6 ->  IsServer: True
2018-07-24 16:24:15.587 - Thread:   6 ->  Autosave in unload
2018-07-24 16:24:15.602 - Thread:   6 ->  Saving world - START
2018-07-24 16:24:15.602 - Thread:   6 ->     Making world state snapshot.
2018-07-24 16:24:15.602 - Thread:   6 ->     Before snapshot.: GC Memory: 1,010,058,000 B
2018-07-24 16:24:15.727 - Thread:   6 ->     After snapshot.: GC Memory: 1,011,863,896 B
2018-07-24 16:24:15.727 - Thread:   6 ->     Directory cleanup: GC Memory: 1,011,863,896 B
2018-07-24 16:24:15.727 - Thread:   6 ->  Saving world - END
2018-07-24 16:24:15.743 - Thread:   6 ->  Session snapshot save - START
2018-07-24 16:24:15.743 - Thread:   6 ->     Checking file access for files in target dir.
2018-07-24 16:24:16.399 - Thread:   6 ->  Session snapshot save - END
2018-07-24 16:24:16.571 - Thread:   6 ->  Unloading Procedural World Generator
2018-07-24 16:24:16.587 - Thread:   6 ->  Network readers disposed
2018-07-24 16:24:16.821 - Thread:   6 ->  Network readers disposed
2018-07-24 16:24:16.821 - Thread:   6 ->  Logging off Steam...
2018-07-24 16:24:16.821 - Thread:   6 ->  Shutting down server...
2018-07-24 16:24:16.946 - Thread:   6 ->  Done
2018-07-24 16:24:16.946 - Thread:   6 ->  MyDefinitionManager.PreloadDefinitions() - START
2018-07-24 16:24:16.961 - Thread:   6 ->  MyDefinitionManager.PreloadDefinitions() - END
2018-07-24 16:24:17.180 - Thread:   6 ->  MySession::Unload END
2018-07-24 16:24:17.196 - Thread:   6 ->  MySandboxGame.UnloadData() - START
2018-07-24 16:24:17.196 - Thread:   6 ->  MySandboxGame.UnloadData() - END
2018-07-24 16:25:15.635 - Thread:   6 ->  Steam closed

photo
1

the server is according to the server manager still running.

photo
1

In my case the server cant get mods from steam (this happens on the autorestarts, not on alls)

photo
1

well i disabled all mods, but still even after clean start, the server does not show up anymore.

i tried to update the server app -> uptodate

i tried to initiate a new world -> still server does not show up, neither on the steambrowser nor in the lan network

photo
1

now me and my friends depend on foreign servers, since my server is not working anymore.

Environment.Is64BitProcess: True

Environment.Is64BitOperatingSystem: True

Environment.Version: 4.6.2 or later (461808)

Environment.CurrentDirectory: C:\WINDOWS\system32

CPU Info: Intel(R) Core(TM) i5-7500 CPU @ 3.40GHz

Memory: 32 GB

photo
1

Hello Kindjal,

Would you be able to provide more informations on your issue? I just tried to reproduce it and game started every time. I tried to Log into Steam inside of DS manager, tried it with running server and also with stopped server.


Thank you.

Kind Regards

Keen Software House: QA Department

photo
2

So I reproduced the issue where DS manager prevents the main game from running. It is reported and someone will look at it as soon as possible.