Copy/pasted ship causing perpetual loading crash, game unplayable

Lukas D shared this bug 15 months ago
Won't Fix

I've encountered a bug that causes the game to repeatedly fail to load a world where there are duplicate "entities". This can simply be a case of copy & pasting a ship, as I discovered when I created a backup ship when testing out some alterations and then logged off for dinner only to find I could not log back in.


This is the error from the Log file:


Exception occured: newEntity: VRage.Game.Entity.MyEntity, oldEntity: VRage.Game.Entity.MyEntityVRage.DuplicateIdException: Exception of type 'VRage.DuplicateIdException' was thrown.


In the end I had to run SE Toolbox to delete one of the ships from outside the game, but not alot of people would actually know to do this (If it weren't for SE Toolbox my save would be permanently inaccessable). It seems rather silly that a mere duplicate ship would cause the game to crash out like this, it must be extremely common to copy/paste things in Creative Mode.

Comments (2)

photo
1

Hello, Engineer!

We cannot reproduce this issue. Can you retest it on the latest version?

Kind Regards

Keen Software House: QA Department

photo
1

Hello Engineer,


Since there are no new comments in this topic and we are still not able to reproduce it, we are closing this thread as outdated.


In case anyone is encountering the same or similar bug, which is not already posted in a different thread, please feel free to create a new thread with all relevant information.


Thank you.


Kind Regards

Keen Software House: QA Department