Client not Syncing Asteroid Voxel Status [MP]

Michael Hughes Dale shared this bug 15 months ago
Considered

Everytime I log into Space Engineers my Space Base which is partially mined into a large Asteroid, The Voxels on my client show as the Original State around the Base. It seems to retain voxel states in some of the mined areas but not all. In order to get things to work and display properly I need to find some place that is the same on both client and server near the affected area, if I dig a little there suddenly the surrounding area syncs up and things are correct. It seem to me that it is very inefficient to have the client constantly downloading the same info over and over, should it not have a local cache that it simply does a checksum on to verify it hasn't been changed on the server?

In any case, whatever the cause, I would greatly appreciate it if it could get corrected. It occurs on many of the asteroids on which the voxels have been modified. It Makes it very difficult to mine properly.

Comments (2)

photo
1

Same with asteroid base

attached picture, straight after connecting in the first time that day, that voxel poking through isnt supposed to be there

video is straight after an F5 reconnect https://youtu.be/K-r-UhcE2o4

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department