Click Noise wehn somebody talks via Voice - Chat

Lord_Anubis shared this bug 16 months ago
Considered

Hello Devs,


My Problem is, that I Can't hear other Players, if they are talkin via Voicechat to me.


I have a Logitech G35 and everytime one of my friends are talking to me via Ingame Voicechat, I here only a very loud clicking soundeffect, but my friends are hearing me in a normal way.


What could it be and how do I solve it?


Thx and Love to you


Lord_Anubis

Comments (8)

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.


We will address all reported issues during future development and we will attempt to fix your issue as soon as possible. We are currently close to a Major release, which is under heavy development and this takes up a lot of our time.


Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards


Keen Software House: QA Department

photo
1

I have this same issue. I was able to hear people in the game and I heard the sound 'freak out' and now every time somebody talks, it just makes white noise/static sound/clicking sound.

This actually seems to be somewhat related to Logitech headsets because I have the issue on the g933. While browsing for others having this issue, it looks like somebody else on Reddit also has the issue on a Logitech headset.


I realize this may not affect a ton of people, but it pretty much ruins our survival server for a few of us.

photo
2

I got this issue as well, Logitech G933 wireless headset.

When someone tries to talk, I hear a click and all sound is lost. I listen to music while gaming, and every single sound is just muted when receiving voice communication from someone else. there is no problem with me sending voice chat to other people, just receiving.


I did find a work around fix though using Virtual Audio Cable. (its a configurable driver acts like you have a wire running between your speaker and line-in audio jack), have the VAC speaker device as active speak, set the VAC Recording device forward what it hears to the Logitech headset

photo
1

That's a perfect summary, I will try the temporary fix later and report back. Keen please fix this. Tired of telling t everyone to type instead of voip.

photo
photo
1

I have the same problem. Also have a G933

photo
2

It is not limited to Logitech headsets, I see people with Corsair also complaining about this on my server. It seems like it has to do with usb headsets

photo
1

I have the same problem. It is not fixed yet in the latest public non beta. I have simple integrated sound card with jacks, no USB.

photo
1

I have the same problem with my Sennheiser GSP 350. This seems to be a problem with surround sound. If Dolby Atmos is enabled the voice is impossible to hear, only squeeking. If Dolby Atmos is turned off there is this loud clicking and the 3D position is acting really weird but the voice is possible to hear.

photo
1

I have Spatial Sound Off and it still reproduces.