Bugs/Memory Leak [SE current stable version]

Sk1ns shared this bug 10 months ago
Won't Fix

Mining with a small ship which has 3 sorters set to white list stone to pass through them and go right to 3 ejecters that are ejecting stone and within 10-15 seconds the game then starts to stutter and there after freeze for 2-3 seconds. This also applies to small connectors that are set to collect all and throw out.

The above then leads on to the game crashing, almost all the time no crash log, however Windows states it is running out of memory and needs to close the game down, which to me points to a memory leak (16GB seems not enough and wants more or it'll CTD).

Another bug, if you will, I start game up, get to menu, load save, then decide not to play and exit to main menu and there after exit game, all is well untill Windows shows an error message pop up that SE has seemingly crashed and I get it every single time, don't even need to load a save up just start game get to menu and exit and it'll still show said error message. Been well over 8 months, if not longer and that hasn't been delt with, surely I'm not the only one who is seeing such things.

Another bug, 'speed of death', meaning player using jet pack and within a foot gets to full speed (110m/s) which leads to player death (still yet to be fixed), well this has now translated to small ships somewhat, pressing 'W' to go forward a couple of times in a row seems to lock it in going forward, even when said key is not pressed.

Yet another bug, Medbay some times does not work, won't refill o2/h2/power. Player would have to save and then load for it to work there after but does not fix as it'll happen again, same applies to newly built Medbays.

Another bug, Some times toolbar keys ',' & '.' do not work if switching from player view/control to spectator. Temp fix is to switch to player view/control to spectator back to player view/control. Seems to lock up the toolbar in one or the other.

All the above happen with and without modded blocks

Comments (1)

photo
1

Hello, Engineer!


Thank you for your feedback, but could you please post all your issues separately including steps to reproduce?

To report a bug into our system it is necessary to have reliable steps to reproduce in order for programmers to fix it.


Any additional information would be greatly appreciated!


Thank you.


Kind Regards

Keen Software House: QA Department

photo
1

With the first bug, I have done as you've stated, very simple in fact. A small grid mining ship, 4 drills, no reactors just batteries, 3 sorters and 3 ejectors, drill ore rocks found on the surface while ejecting stone, game will stutter and then freeze, for me it leads to a memory leak and therefore CTD without fail. This is for single player only, cannot comment for online play. Could do a Video, however it may well cause said video to not play due to CTD. If able, will try.


Same with the Medbay bug, which was if it doesn't refill H2/o2 and power then player would have to save and thereafter load that save for it to work, shouldn't be that way. happens with fresh new starts, at times shortly after starting.


When the memory leak is fixed which is rather tiring to put up with, due to it happening within 5 minutes most of the time now that leads on to the game CTD (has also caused windows 7 and game to crash, leaving a manual restart due to blank screen), then I'll report each bug seperately. This one thing is making it near impossible to attempt to give any more info on how to reproduce anything else. At best, some of this has come about since your last update/hotfix.


Pointless me stating anymore due to what it say's on the right of my post.

photo
1

Hey Sk1ns -- I'm an old player of SE and I'd be happy to help you showcase the bug if you need any help. I'll need some blueprints though -- can you share blueprints for the mining ship and a platform with the medbay bug you are seeing?

As for the "load a save, then quickly exit the game" -- I tried a bunch of different saves in my folder doing this method, and I never got over 5gb of memory, and couldn't reproduce the crash symptoms. FWIW, I'm on an older nvidia 980 with update to date drivers, windows 10, and a an old 6th gen overclocked i7 -- all on my desktop.

Upload those blueprints and post the urls here and I'll test your medkit and sorter ship to see if I can reproduce the issues with those.

photo