Block Groups disappearing when someone disconnects

Jaakko Moilanen shared this bug 2 months ago
Solved

This issue appeared after 1.189.

After a non-host person leaves a P2P server, every block group from at least every friendly ship disappears.

This issue came to light in a modded world, but was successfully replicated in a completely new modless world.

Comments (49)

photo
1

However, it seems that if a non-host person force quits the game instead of exiting to main menu (we tested the Steam Overlay's force quit in the upper right corner), the block groups will not disappear.

photo
1

We are reproducing this in "Never Surrender" mode without any mods. The force quit option indeed works for us aswell. A normal disconnect deletes all Block groups.

photo
3

To add to this, I've noticed that the groups remain on the hotbar, as "removed block" icons. If the group is recreated in the terminal, the hotbar icon will switch back to being whatever icon the group has. Hopefully this will save people some headache when recreating their groups.

photo
2

Happened to us earlier, successfully replicated with another friend:

https://imgur.com/a/yrhGtSk

photo
1

Quick note, issue also started after the recent update (1.189)

photo
photo
2

Same happening with me. Replicated many times!

photo
3

Hi guys,

We were able to reproduce the issue, but with different repro than player logging off the server. Hopefully it will fix also this issue, but can you provide more information. Was it DS or Lobby multiplayer game? Can you upload blueprint of the grid loosing the groups? It would be very helpful.

Thank you very much for your feedback and have a nice day :-)

photo
1

For me it's happening on a lobby server with friends, happening on both modded and vanilla grids. I've lost groups on both the ship I'm currently working and on a test grid consisting of a few armor blocks, reactors and thrusters, doesn't seem to be specific to one blueprinted ship. Regardless, how do you want us to provide the blueprint, workshop link or a physical file?

photo
1

I just did another test to replicate the bug, this time it was with my modded ship which I first discovered the bug on. Got a friend in, they disconnected and all groups in the ship disappeared. However I tried it earlier today on a vanilla world with no mods and it didn't delete the groups. Yesterday I replicated it on that same vanilla world and got the glitch (with a different friend) that removes the groups. Seems a bit irregular, all happening on lobbies with friends

photo
1

Same bug happening to us and it's driving us all insane. Playing multiplayer hosted from my machine. Whenever someone joins or leaves the game all control groups are deleted. Meaning every mining ship, every solar array, and the complicated ship assembly array needs to be re-grouped to work again.


This is rendering the game near on unplayable. It has even happen to us on re-entry from orbit the groups just greyed out as a friend joined at the wrong time, leaving us scrambling to regroup the engines just in time to slow and not crash.

photo
1

My experience has been in a Local Multiplayer world with 2 friends. If either of them disconnects normally, every block group of every grid is gone.

photo
7

Hello, Engineers!


We reproduced this issue of disappearing groups when a player logs off. Our programmers will look at it.

Thank you all for your cooperation.


Kind Regards

Keen Software House: QA Department

photo
1

Thanks guys!

photo
1

It seems that even when entering a cryo chamber, groups disappear, same grid or not. We are on lobby multiplayer.

photo
1

AND?!?!? where is the fix!?

photo
3

I really hope they fix this issue very soon. This is a mayor bug. My Large ships Had over 20 groups with lots of blocks in them. All gone.

photo
3

Agreed, this bug is really hurting the world I am playing on right. Please fix!

photo
1

I've had to pause a few projects because of this, but I'm sure they're working as fast as they can

photo
2

@Euan White: Don't count on a fix anytime soon, googling this issue brings up lots of previous bug reports for this issue going back to 2014 and doesn't look like they have ever fixed it. I hope I am wrong and they do fix it soon as grouped blocks are a fundamental game mechanic and this bug has effectively rendered the game unplayable for my friends and I.

photo
2

@Robin Hood: Strange how it's only just appeared, but I guess certain criteria (and a lot of bad luck) have been met

photo
2

Got that same bug. it's really pissing me off

photo
2

same its really starting to get to me >< i have to reset all grps every time one of my friends leave >< fix it asap plz

photo
4

I just stopped playing the game. It was unplayable.


It's still in alpha state, despite their communication.

photo
3

Fix the goddamn bug.

photo
2

@Keen Support

Any progress on a fix?

photo
2

Yes please give us an update!

photo
2

Indeed this needs to fixed asap. I find it very much impossible to really control ships well without groups, and its a major amount of precision work to recreate all the groups from the scratch every time. Not fun.

photo
3

can we please get some sort of ETA on this my friends and I are starting to go off the game because its a pain in the back side to keep redoing them in so MANY Ships!!! its kinda game breaking / game killing thanks?

photo
1

Guys I have come up with a work around using timer blocks in your ship builds.

Basically instead of grouping all the engines for example I now use timer blocks to to turn the engines on and off as an action (upto 8 engines per timer block) leaving the final 9th slot to "start" a second timer block to control another 8 engines and so on. Then have the lead timer bound to a number button to start. There by pressing the number button can turn on or off all engines. Or set batteries to recharge etc..


My only advice with this setup is to have a battery set to recharge mode in your build linked to a number key to ensure your build always has power available for the timer blocks, a kinda starter motor if you will. Otherwise the build could run out of power and the timers will be useless.


But this method ensures you can make a build without any grouped blocks to be deleted,

photo
2

Still a current issue, would love to have an ETA on the fix.

photo
2

Fix please

photo
2

FIX THIS INMEDIATLY GAMES IS UNPLAYABLE

photo
3

dev please do sometthing, your game is not supossed to be in alpha anymore

photo
1

It also happens that sometimes other blocks are added to groups on their own.

photo
3

Fix this goddamn bug now! This is game breaking and you are losing customers by not acting.

photo
2

Game is literally unplayable with this. Please make it a priority.

photo
2

Fuc**ing fix this goddamn bug NOW!

photo
1

New "big" update, but no fix. DAFUQ KEEN!!!

photo
4

I appreciate that fans of the game (myself included) are upset that this bug is taking some time to be fixed.

However, I would suggest to those using rude or inappropriate language that such somments will not help motivate the developers to work any faster. Personally, I don't improve my performance when I experience verbal abuse, and I'm doubting the developers will appreciate it either.

Like most of us I've been playing this game a long time and I know the devs work extremely hard to resolve to issues we report. I appreciate their support and the countless hours they continue putting into the game, even when they could have moved on to other projects.


I've managed to keep playing the game by using timer blocks to create block groups. It's far less convenient, but it allows me to continue enjoying the game while I wait for the bug to be fixed.

Thank you for taking the time to read this, and for possibly moderating your comments to be more constructive.

photo
1

Instead of making players maybe pay more and adding other random shit(disposal systems), it would be better if they had fixed this bug. I had kinda expected an hotfix a few weeks ago TBH. I think we are allowed to complain.


Also, I would need several timers to make one set of hangar doors to open/close. The game just isn't doing what it should be doing. And it needs to be resolved.

photo
1

I'm not suggesting that the bug doesn't need to be fixed, nor am I suggesting timer blocks are the optimal workaround (it took six to make a small mining ship operable). I'm also completely understanding that people are upset and are validated in voicing an opinion about how the bug affects their game play.


I'm also aware that children play this game and are able to read this public forum - I have to ask myself what kind of example I want to set for those kids, before I post a comment.

All I'm suggesting is that comments with rude or inflammatory language/tone are not necessary and will not help the situation.

Keen absolutely needs to be aware of how passionate we are about this game, and how inconvenient this bug is, though out of respect for them, and anyone else reading the comments, I suggest choosing our words and tone carefully.

photo
1

ppl are right this is a game breaker for ppl who want to play with friends or on servers i for my self breaks the game so my friends end up not playing due to grp names keep deleting there self's when ppl disconnect

time blocks are not a fix or answer to the issue ,


this is how the bug breaks for us


so this is the BUG

also same on dedicated


Am Host >

I Load save >

PPl join >

group names are still fine >

until one person Leaves >

Group names Delete there self's >

ppl rage >

i have to reload a later save to get the grp names back >

ppl rage >

due to there progress there lost >


So Dev can you please fix this bug me loading a later save is not a fix either

photo
2

The changelog states that the bug has been fixed, and my friends have been able to play without error. I'm not sure if you guys have checked the fixes in the latest update but it's right there. I have yet to try it myself but hearing good things

photo
1

Have you managed to test your account?

photo
1

I just wanted to say thank you to Keen for your continued support.

SE is easily my favorite game (500+ hours), and I recently got my wife to start playing it with me.

We each purchased the new decorative pack to show our support for you.

Keep up the great work, I can't wait to see what updates will come out next.

photo
1

Hey thanks alot for fixing the bug!

photo
1

All working now, thanks Keen!

photo
photo
3

Hello, QA Department


Unfortunately, the game has become unplayable for me and my friends.

The game has been getting worse since release anyway (minor bugs everywhere) so you have to restart the game very..very often. We have many ships and a HQ with a lot of blockgroups. With the long loading times (5 min for starting, up to 8 min loading save with ssd), unacceptable.

We decided to take a look at the end of this year and hope that the game will reach the quality it had before the early access release.


Until then


Players of the Faction Nemesis

photo
1

Appreciate the fix guys!