Armor Blocks Allowing Damage to Pass Through

Alex L shared this bug 5 months ago
Considered

WHAT IS HAPPENING

We've noticed that our rovers are randomly becoming damaged or destroyed unexpectedly while driving, even at slow speeds. We've been using half armor blocks to protect the underside of our rovers but components within the interior of the ship will become damaged or destroyed while the armor blocks themselves are untouched or only lightly damaged. Out of the 20ish rovers built on our server, 17-18 have been destroyed by this. At the moment rovers are non-usable until this is fixed.

WHAT SHOULD HAPPEN

Armor blocks should provide insulation from damage to the blocks behind them in the event of a collision. If I create a sheet of armor and place a battery on top, then drop the sheet only the armor blocks should be damaged (unless the armor blocks were destroyed). The battery should not be destroyed first.

HOW TO REPRODUCE

Place a sheet of steel armor half blocks then a sheet or batteries (or other components) on the other side. Now, drop or hit the armored side of the sheet until the components are damaged. The armor blocks in most cases will still be at 100% whereas all the damaged was transferred to the internal blocks, defeating the purpose of using armor in the first place.

Comments (1)

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department