[187] Air vent uses full power after filling a room

Digi shared this bug 15 months ago
Need More Information

Apart from air vent's power usage being really high, especially for the smallship variant, it also has an issue that makes it use the operational power all the time.


For context, it has these values in the definition (power is in MW):

<OperationalPowerConsumption>0.33</OperationalPowerConsumption>
<StandbyPowerConsumption>0.001</StandbyPowerConsumption>


You can see in the screenshot attached how much power it actually uses after I've filled a room.


Because the game doesn't show the airvent's power usage, I've included a mod script in order to see the power usage easier.


STR:1. Create a local mod and add this script to it: https://pastebin.com/raw/Jsahc48G

2. Add the mod to a creative world and load it.

3. Preferably in space, place an oxygen tank and an air vent on one end of it.

4. Make a sealed room around that, with a door and leave the door open.

5. Place a battery or reactor.

6. Turn "Show In HUD" on for the airvent so the mod shows you its power stats.

7. Close the door to seal the room and watch the power usage.

Comments (3)

photo
1

I also have this. I've taken to turning off the vent after pressurizing the room because 33 kW is non-negligible.

photo
1

thats 330kW unfortunately :(

photo
photo
1

Well, sometimes the depressurization works even when the Air Vent is turned off ;-)


Currently I use it to keep my Oxygen Tank full of O2 on Alien planet ...

photo
1

Hi guys,

please retest it on current version (1.189.040) and let me know if it works or not.

Thanks!

photo
1

It's still an issue but with different values because they got changed.

It starts off with 0.001 MW (with room not sealed) and when it pressurizes it gets stuck at 0.1 MW even after it's done pressurizing (with my character not inside the room) and even after unsealing the room.

The STR in the topic still applies, you could add step 8: Open the door to unseal and see how power usage does not change.

photo