[1.191.020] Crashing Steam At Startup

Curtis Tate shared this bug 2 months ago
Considered

Never done one of these before so bare with me as I may not initially provide the correct information.

As of this newest update, I cannot get Space Engineers to the main menu. Every time I launch SE from Steam (from desktop mode or Big Picture and Public or Beta), it locks at a black screen after displaying the splash screen. I Alt-Tab to find SE still running but Steam is gone, and Steam suddenly not running seems to lock SE up during loading. While I have had an occasional Steam crash mid-game while also pushing it's web browser pretty hard, I've never in my years of playing SE had this particular problem, and it also didn't entirely lock up SE like this. And even though Steam is behaving completely normal with anything else (other games w/ workshop and market integration, chat, ect), I tried opting out of its Beta to see if it may be some API thing they did on their end and I'm getting the exact same behavior. Not ruling anything out, but I'm really doubting its on Steam's end of things. But the way it's crashing Steam RIGHT on startup every single time leads me to believe its something with the communication between SE and Steam.

As far as my computer is concerned, no hardware changes in the last 1.5 years and I've just checked for newest drivers w/ the same behaviour:

Windows 10 (genuine), Intel Core i5-6500 @ 3.2GHz (stock OC), 16GB DDR4 Ram, Radeon RX480 4GB, SSD for OS & Steam and HDD for games both less than half full.

The only thing I've yet to do so far is reinstall SE, since I'm not entirely sure what will be deleted forever and what got saved to the cloud. Any tips on how to preserve that data would be appreciated, regardless of this bug.

Beyond this I'm really not sure how to produce the proper report for this, since the standard SE crash report prompt never even pops up; I have to end up closing SE through Task Manager. Is there a log file somewhere that I can manually retrieve and send?

edit: Forgot to mention I own the recent deco DLC but not the deluxe edition or style pack (yet) if that makes any difference. Also no Discord running or any video capture or anything.

edit 2: read through troubleshoot page, found the log file.

Comments (5)

photo
1

Update: Just tried reinstalling SE, still crashes on startup. Also tried rolling back to previous versions, no difference. I CANNOT PLAY ANY VERSION OF THIS GAME NOW. How is this possible? Prior to and during this update, I have made NO RECENT HARDWARE OR SOFTWARE CHANGES. I'm having no problem with Steam launching ANY other games. In fact I cannot get Steam to crash any other way right now, only attempting to run SE will do it, and only since this update. Whatever has changed with this update, it either changed something somewhere that SE installation isn't touching or... I have no idea.

I was reading through the .log file and I see something to the effect: "Steam-OwnsGame - false" That doesn't sound good. I very much own the game and have it properly installed to the best of my knowledge. What happened? Is this a false flag?

photo
1

Oh wow. I'm seeing the developer responses to game crashing bug reports are taking upwards of 5 months just to get a reply asking for more info!? After over 4 years of playing this, I can't even get the game to start now and seeing that response time pretty much flattened me. If I ever find that the game starts up correctly, I will post it. Currently, SE does not start up; it crashes Steam immediately and reliably as I described before.

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

OK, calmed down and ran through the troubleshooting tips again. Disabling the Steam Overlay got it running again. Enabling it causes it to crash reliably just before the Keen logo, but only since this update.

I suppose we can mark this as solved, as I now have a way to play the game, and I understand that Steam is Valve's business, but Steam hasn't been updated in the time that 1.191 has been released (just tested with 1.191.023, Steam Overlay being enabled still crashes on startup, log included) and I've always played with the Overlay enabled due to the integrated access to the workshop and such. However, I can actually run it again, try out these new features, and right now I'm just thankful for that. I apologize for my tone earlier; I've got over 5,000 hours invested, new features got teased, and then this.

Still needs a fix, as the Steam Overlay is pretty baked into SE and its features, but probably not hotfix priority.

To summarize: If Steam is crashing on SE startup (causing SE to crash) since the last update (1.191.023), disable the Steam Overlay. The Overlay is working fine for every other title I've tried since this started with SE, so I'm still led to believe its something with the communication between SE and Steam at startup. Since that's an issue that may involve the other or both parties, I'll just look forward to using the Overlay again in the next update.

PS according to the log, now it looks like I'm getting an exception regarding a write issue or corrupt RAM, which I've heard quite a few different issues refer to before but never seen myself. Is 16GB not enough to start SE with the Steam Overlay enabled anymore? I doubt it and I'm still leaning toward communication between the two being the issue, not either one exclusively.

photo
1

New Steam update released today seems to have fixed the overlay issue. This issue is solved.