[1.190.0] [DS] Ship not moving/slowing down after some time

LordTylus shared this bug 4 months ago
Need More Information

Hello there,


today I have a hard to reproduce issue.


On our server every now and then people have problem with Ships being basically stuck on their velocity vector.

They cannot be accelerated or decelerated.


When stopping them using Space Master it will just stay in that exact spot either till server restart, or cutting and pasting it.


It happens every now and then. So I cannot say it a major problem, but it appears also often enough that I would like it fixed.


Sadly I dont have logs to provide right now and I dont know the steps to reproduce as It never happened to me yet.


However I am reporting this because maybe someone else from the community will find it and have some information. Or maybe it already is a known issue.

Comments (3)

photo
1

Hello, Engineer!


Could you please provide us with more information regarding the issue you reported? To report a bug into our system it is necessary to have reliable and exact steps to reproduce in order for programmers to fix it.


Any additional information would be greatly appreciated!


Thank you.


Kind Regards

Keen Software House: QA Department

photo
1

I had this bug twice back in December on a DS. Both times I panicked and didn't record until I gave up or felt comfortable looking away from the issue. The recordings were only to show my faction mates what happened to our expensive components and defense drone should it get destroyed. The solution was to grind all ship controllers on the grid.

The first time my welder ship assumed a mildly fixed speed on a fixed vector. It was full of extremely expensive mod items. I went to fly around my base and halfway to my destination the ship started drifting away uncontrollably. It had a mildly fixed velocity, dampeners helped a little but didn't fully stop it and turning off the dampeners gave it a fully fixed velocity. The vector was fully fixed, attempting to fly perpendicular to the vector caused it to rubberband back to the vector repeatedly. I ground down half the ship trying to fix it, note the components floating in space and the half a ship I'm trying to salvage. I didn't grind the cockpit as I would have no way to control it once gone. You can see the dampeners fighting the vector. I tried moving in all directions in case the DS or controller believed I had a key pressed in (WASD C/Space). I gave up on it. :'(

https://www.youtube.com/watch?v=po1flrdMIhI&feature=youtu.be

The second time my remote defense drone assumed an expanding orbit and an increasing speed. I was moving it remotely when it started drifting away. It was going about 10m/s when the bug triggered. It was orbiting my base, the speed was increasing and the orbit was expanding. The speed peaked at 92m/s. I returned to base to grab my welder ship mk2 and docked on it with landing gear. My welder ship only partially slowed it down. Once I ground the remote control away it started to fully slow down. I was terrified it would crash into an asteroid so I didn't start recording until after I docked my welder ship on it. The recording wasn't very informative so I didn't upload it.

I don't know what triggered this bug or how to reproduce it. The ship controllers seemed to be applying force in the direction is was being told to go when the bug triggered. The thrusters were not pushing it in the vector it was heading, in fact it was trying to stop with the dampeners. I tried everything to fix it without grinding the controller. If I allowed the ship to partially slow with dampeners and turned the entire grid off, it would accelerate back to the fixed velocity without power.

Hopefully this is enough info.

photo
photo
1

I have exacly same issue. Ships follow their etor again if you step in cocpit for a sec and accelerate a little. Very inoing for someone who use a lot of drones as I do.