[1.187.1] - DS - Convert to Ship causing rogue acceleration

No Thanks shared this bug 15 months ago
Won't Fix

Last night playing on a DS I had an incident wherein After converting a "station" back into a ship the grid in question accelerated rapidly and uncontrollably into a nearby asteroid. I cannot be certain how exactly to reproduce this bug as I don't have admin on a DS where it can be tested, however...


1). connect one or more grids via connector to a large grid that is not static.

2). convert ship into a station.

3).

4). Convert station to a ship.


I have no guess as to how well this can be reproduced. The DS in question runs a few mods, none of which should affect physics. Best details I can give are as follows... The large grid (base) had a large grid miner, a large grid welder ship, a small grid scout ship, and a small grid projector attached at various points before being converted to station... It's fair to note this isn't a new setup except that the large grid miner was recently constructed... the others had been tagging along on my base for some time without issue.

After logging out for the night and logging back in the next day, I converted the base to a ship and it accelerated out of control and clanged into an asteroid, temporarily bottoming out the sim speed to about .2 or so. At the end of it, the small scout and large miner had survived, as well as about half the base. I was asked by the server owner to put this report in so here it be.

Comments (2)

photo
1

Hello, Engineer!

we cannot reproduce this issue. Can you test it on latest version?

Kind Regards

Keen Software House: QA Department

photo
1

Hello Engineer,


Since there are no new comments in this topic and we are still not able to reproduce it, we are closing this thread as outdated.


In case anyone is encountering the same or similar bug, which is not already posted in a different thread, please feel free to create a new thread with all relevant information.


Thank you.


Kind Regards

Keen Software House: QA Department