[1.187.089] Projector DetailedInfo and API not updating

unknown engineer shared this bug 13 months ago
Considered

Basically this is a copy of this old report which still seems to be in game.

This Video shows the projector not updating its DetailedInfo and the API

Reproduction steps:

# use e.g. Easy Start world on a dedicated server

# Paste blueprint from workshop ( http://steamcommunity.com/sharedfiles/filedetails/?id=1257203828 ) or build your own projector setup

# weld first projection

# note that DetailedInfo and values from IMyProjector API updates normally as projection is welded

# cut away welded grid

# weld subsequent projection

# note that DetailedInfo and IMyProjector API does not update anymore


Observed behavior:

On first welded projection, projector DetailedInfo and IMyProjector API update normally. Any subsequently welded projections will not update the DetailedInfo and values from IMyProjector API until you manually click something in the Projector Terminal. e.g. "show only buildable".


For the provided blueprint, initially CustomData states 0/25 blocks are welded and IMyProjector.RemainingBlocks is 25. Upon welding, DetailedInfo will update as the projection gets welded.

When you cut away the resulting small ship and weld the projection again, DetailedInfo and the IMyProjector API is not updated any more. It will constantly state 0/25 blocks are welded and e.g. IMyProjector.RemainingBlocks is stuck at 25.


The PB in the blueprint Echos the RemaingBlocks on an Update10 Interval, check its terminal to get the current value.


Expected behavior:

Projector DetailedInfo and API is updated during the welding process on first and subsequent welding operations.

Comments (4)

photo
1

Bug still exists in [1.187.2], it keeps breaking my 3D-Printer.

My observered behaviour matches the description, with one addition: Reenabling the projector does not fix the problem.

Does anyone have a Quickfix for this?

photo
1

Try removing, and re-adding the blueprint... This will likely mess up grouping though.

photo
1

Did try that without positive result.

The counter gets updated, yes - but only once when the blueprint is reloaded. It still stops counting afterwards.

Reloading the world helps, but that is hardly agreeable, especially in Multiplayer.

photo
photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.


Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards


Keen Software House: QA Department