Can't attach to, or extend my main large grid anymore

Faskimy shared this bug 4 months ago
Submitted

I started a new survival game two days ago, no mods. I proceeded to build a nice house, making many adds and removes overtime. Then I decided to remove a shelf, and tried to put it somewhere else, but I couldn't. In fact, after some testings, I realized that my shelf wouldn't attach anywhere on my house, including to its original spot.

I reloaded my game file, with or without exiting to Windows. It didn't help. I started a new game in creative mode, and then, I was able to add shelves to walls normally. I reloaded my first game, the problem is still there.

Shortly after that, I also realized that I couldn't add anymore walls, roofs, supports, or anything else to my house, and that any object such as chest, crate or spinning wheel would bounce off the surface as a moving object when I tried to drop them on the floor. Has my main large grid somehow changed state? Turning into a giant dynamic object itself? Immobile, only because it is stuck in the ground? Or is it just a bug?

Simply by creating a new large grid (building a wall in the grass away from my house) I could add shelves normally there.

Comments (2)

photo
1

Two days after the problem appeared, it disappeared by itself. I did nothing in particular, except saving my next progression under a new name and starting a whole new house away from the first one. Then, I went back to my original location to get some stuff, tried some shelves or walls, and it worked!

photo
1

Couple hours after being fixed by itself, the problem came back. There's something I do that generates this glitch. Here's the details of what happened and the tests I've made, in case devs would mind :

After the problem disappeared, I happily continued upgrading my domain for couple hours. I saved frequently under several different names, in case the problem came back.

Everything was fine until I went to an iron mine to replenish my iron stocks. I already went to that place before, the mine is around 15 minutes away from my base by walk. I went by fast travel. I spent 30-45 minutes mining for iron, then came back to camp again, fast travel. The bug was there again.

I uploaded an earlier save (2 hours prior to that) : the bug wasn't there yet. I wondered if, maybe, the fast traveling was causing the glitch to appear. So while still in the earlier, unglitched save, I fast traveled to the iron mine and came back. The glitch appeared. At this point, I'm pretty convinced that something related to fast traveling is causing this glitch.

Now, what made the glitch disappear the first time I fixed it? I don't know, I did many things during that time, including starting my future site. So I went back there, spent some time around the unfinished supports I put there, unsure of what to do. Then I came back to my main house, hoping it would miraculously make the glitch disappear again, but it didn't. I noticed one thing though. The bed mark and house symbols on my compass....

The bed mark appeared when I first claimed the bed, as usual, way before any of that, glitchs and testings, happened. And when I first came back in my base to find it fixed, I also noticed that my bed mark on my compass had disappeared. My bed wasn't claimed anymore, and I reclaimed it. Weird, but OK. Then I moved on.

The second time I approached my base, hoping the glitch would be gone, I noticed that my bed symbol on my compass was there. And when I arrived there, the house was still glitched.

So, conclusion, there's something I did to fix it the first time, I don't know what exactly that somehow made my grid "reset". Unclaiming my bed in the process, but also removing the bug.

As for the source of the bug, I though it was fast traveling, but then something weird happened. When I load my unglitched save again, then I travel back and forth to my future house spot, the glitch don't appear. Immediately after that, I fast travel back and forth to my iron mine, and the glitch appear... So the glitch appear on SOME fast travels? What are the differences between my future house site and the mine? The future house is nearer, in the same biome, while the iron mine is more distant, in the south, in the desert.... But it's weird....

Hoping these testings and explanations will somehow be useful.